aboutsummaryrefslogtreecommitdiff
path: root/office/calibre/calibre.SlackBuild
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2020-12-05 09:38:29 +0100
committerRobby Workman <rworkman@slackbuilds.org>2021-04-17 23:15:53 -0500
commit46f49b60949d2808e859349b32cae9153d4281d1 (patch)
tree68eaef3cd9ef05b6dad125db4ea90eec4ca2b33c /office/calibre/calibre.SlackBuild
parent0fc9e63742a1f9ef06bee6f9c7afdfb06ae94cf7 (diff)
downloadslackbuilds-46f49b60949d2808e859349b32cae9153d4281d1.tar.xz
office/calibre: Updated for version 3.48.0.
Deps: changed cssutils with css-parser, added python2-pillow. Patched for qt-5.15.x and the newer icu4c Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'office/calibre/calibre.SlackBuild')
-rw-r--r--office/calibre/calibre.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/office/calibre/calibre.SlackBuild b/office/calibre/calibre.SlackBuild
index 048798bcf9e0..ef72f00a091a 100644
--- a/office/calibre/calibre.SlackBuild
+++ b/office/calibre/calibre.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=calibre
-VERSION=${VERSION:-3.34.0}
+VERSION=${VERSION:-3.48.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,6 +70,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch for the newer icu4c
+patch -p1 < $CWD/patches/icu.patch
+# Patch for qt-5.15.x
+patch -p1 < $CWD/patches/qt-5.15.patch
# Remove desktop integration. We'll do that later.
patch -p1 < $CWD/patches/remove-desktop-integration.patch
# Fix calibre module location.
@@ -79,10 +83,6 @@ patch -p1 < $CWD/patches/calibre-no-update.patch
# Remove calibre portable scripts.
rm -f resources/calibre-portable.*
-PYTHONVER=$(python -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
-export SIP_BIN=/usr/bin/python2-sip
-export SIP_INC_DIR="/usr/include/python$PYTHONVER/python2-sip"
-
OVERRIDE_CFLAGS="$SLKCFLAGS" \
OVERRIDE_LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
python setup.py build