aboutsummaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2022-03-01 23:37:14 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-03 16:25:42 +0700
commit7cb8913dee30f3d4c6b7b0606ba728c341893664 (patch)
tree8b223cb2026ac2ff0c90868a7c93dafe4ee964de /network
parente764918d61b9f8a052de0cb0b9be549fe2c69a02 (diff)
network/mldonkey: Removed.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/mldonkey/README12
-rw-r--r--network/mldonkey/doinst.sh4
-rw-r--r--network/mldonkey/mldonkey.SlackBuild138
-rw-r--r--network/mldonkey/mldonkey.desktop9
-rw-r--r--network/mldonkey/mldonkey.info14
-rw-r--r--network/mldonkey/mldonkey.pngbin3818 -> 0 bytes
-rw-r--r--network/mldonkey/slack-desc19
7 files changed, 0 insertions, 196 deletions
diff --git a/network/mldonkey/README b/network/mldonkey/README
deleted file mode 100644
index e780093e1eb0..000000000000
--- a/network/mldonkey/README
+++ /dev/null
@@ -1,12 +0,0 @@
-MLDonkey is an open source, free software multi-network peer-to-peer app.
-
-By default, this SlackBuild will build MLdonkey without a GUI. Without a
-GUI, you can control mldonkey by connecting to localhost:4080 with your
-web browser.
-
-If you want to build MLDonkey's GUI, you'll have to enable it with the
-GUIOPT variable like this: GUIOPT=yes ./mldonkey.SlackBuild
-
-Be sure not to have ocaml and lablgtk already installed when compiling
-this as build may break (mldonkey seems to need its own versions of the
-above dependencies).
diff --git a/network/mldonkey/doinst.sh b/network/mldonkey/doinst.sh
deleted file mode 100644
index 4e8ba7071dea..000000000000
--- a/network/mldonkey/doinst.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
diff --git a/network/mldonkey/mldonkey.SlackBuild b/network/mldonkey/mldonkey.SlackBuild
deleted file mode 100644
index 7835af56fa41..000000000000
--- a/network/mldonkey/mldonkey.SlackBuild
+++ /dev/null
@@ -1,138 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for mldonkey
-
-# This script is originally written by Antonio Hernández Blas and is
-# currently maintained by Grissiom.
-
-# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
-# Copyright (c) 2009, Grissiom <chaos.proton@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are met:
-# 1.- Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
-# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
-# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=mldonkey
-VERSION=${VERSION:-3.1.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-GUIOPT=${GUIOPT:-no}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# This avoids downloading tarballs when the SlackBuild is running
-mkdir -p patches
-ln -s $CWD/ocaml-3.12.0.tar.gz patches/
-ln -s $CWD/lablgtk-2.14.2.tar.gz patches/
-
-# OCaml 3.10/3.11 don't work with gtk1, so ingnore the gtk1 choses and let
-# configure to choose a proper lib.
-if [ "$GUIOPT" = 'yes' ]; then
- GUIOPT='--enable-gui=newgui2'
-else
- GUIOPT='--disable-gui'
-fi
-
-# Change the O6 to something saner
-sed -i "s/O6/O2/" config/Makefile.in
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-batch \
- --build=$ARCH-slackware-linux \
- $GUIOPT
-
-make -j1
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-if [ "$GUIOPT" = 'yes' ]; then
- mkdir -p $PKG/usr/share/{applications,pixmaps}
- cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
- cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- distrib/*.txt docs \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-[ "$GUIOPT" = "yes" ] && cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/mldonkey/mldonkey.desktop b/network/mldonkey/mldonkey.desktop
deleted file mode 100644
index d44d9e349544..000000000000
--- a/network/mldonkey/mldonkey.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=MLDonkey GUI
-GenericName=MLDonkey GUI
-Comment=The MLDonkey GUI
-Exec=mldonkey_gui
-Icon=mldonkey
-Terminal=false
-Type=Application
-Categories=Network;
diff --git a/network/mldonkey/mldonkey.info b/network/mldonkey/mldonkey.info
deleted file mode 100644
index 8d2907a4bc58..000000000000
--- a/network/mldonkey/mldonkey.info
+++ /dev/null
@@ -1,14 +0,0 @@
-PRGNAM="mldonkey"
-VERSION="3.1.6"
-HOMEPAGE="http://mldonkey.sourceforge.net"
-DOWNLOAD="https://github.com/ygrek/mldonkey/releases/download/release-3-1-6/mldonkey-3.1.6.tar.bz2 \
- http://caml.inria.fr/pub/distrib/ocaml-3.12/ocaml-3.12.0.tar.gz \
- http://www.math.nagoya-u.ac.jp/~garrigue/soft/olabl/dist/lablgtk-2.14.2.tar.gz"
-MD5SUM="d73a925fb3559eed2c1d91fdeed1153a \
- 3ba7cc65123c3579f14e7c726d3ee782 \
- bad77680a72dab8b915cae99d1ec9b1f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Grissiom"
-EMAIL="chaos.proton@gmail.com"
diff --git a/network/mldonkey/mldonkey.png b/network/mldonkey/mldonkey.png
deleted file mode 100644
index ee67b482b852..000000000000
--- a/network/mldonkey/mldonkey.png
+++ /dev/null
Binary files differ
diff --git a/network/mldonkey/slack-desc b/network/mldonkey/slack-desc
deleted file mode 100644
index e73db4365538..000000000000
--- a/network/mldonkey/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mldonkey: mldonkey (A multi-platform multi-network peer-to-peer client)
-mldonkey:
-mldonkey: MLDonkey is an open source, free software multi-network
-mldonkey: peer-to-peer application.
-mldonkey:
-mldonkey: Homepage: http://mldonkey.sourceforge.net
-mldonkey:
-mldonkey:
-mldonkey:
-mldonkey:
-mldonkey: