aboutsummaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2010-05-12 23:32:46 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-12 23:32:46 +0200
commitd6cde1adb9c45044dfa87ead20287e30c640c51e (patch)
tree331e387407551a3e8bab6ba171df0a372004649d /network
parent7193c26929abe72cad3609559d123341ec74626e (diff)
downloadslackbuilds-d6cde1adb9c45044dfa87ead20287e30c640c51e.tar.xz
network/shorewall-perl: Added to 12.2 repository
Diffstat (limited to 'network')
-rw-r--r--network/shorewall-perl/README11
-rw-r--r--network/shorewall-perl/patches/patch-perl-4.2.10.191
-rw-r--r--network/shorewall-perl/shorewall-perl.SlackBuild86
-rw-r--r--network/shorewall-perl/shorewall-perl.info8
-rw-r--r--network/shorewall-perl/slack-desc19
5 files changed, 215 insertions, 0 deletions
diff --git a/network/shorewall-perl/README b/network/shorewall-perl/README
new file mode 100644
index 000000000000..06cfead3763b
--- /dev/null
+++ b/network/shorewall-perl/README
@@ -0,0 +1,11 @@
+Shorewall-Perl (Perl-based compiler for Shoreline Firewall)
+
+The Shoreline Firewall, more commonly known as "Shorewall", is a
+Netfilter (iptables) based firewall that can be used on a dedicated
+firewall system, a multi-function gateway/router/server or on a
+standalone GNU/Linux system.
+
+This is the perl compiler part of Shorewall that allows faster
+compilation and execution than the legacy shorewall-shell compiler
+
+You will also need shorewall-common (or shorewall6-common for IPV6 support).
diff --git a/network/shorewall-perl/patches/patch-perl-4.2.10.1 b/network/shorewall-perl/patches/patch-perl-4.2.10.1
new file mode 100644
index 000000000000..505bf3387dac
--- /dev/null
+++ b/network/shorewall-perl/patches/patch-perl-4.2.10.1
@@ -0,0 +1,91 @@
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/changelog.txt shorewall-perl-4.2.10.1/changelog.txt
+--- shorewall-perl-4.2.10/changelog.txt 2009-06-18 07:04:06.000000000 -0700
++++ shorewall-perl-4.2.10.1/changelog.txt 2009-06-18 13:22:33.000000000 -0700
+@@ -1,3 +1,7 @@
++Changes in Shorewall 4.2.10.1
++
++1) Correct r2q Calculation
++
+ Changes in Shorewall 4.2.10
+
+ 1) Avoid 'large quantum' when adding HTB qdisc on fast interfaces.
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/install.sh shorewall-perl-4.2.10.1/install.sh
+--- shorewall-perl-4.2.10/install.sh 2009-05-29 18:34:08.000000000 -0700
++++ shorewall-perl-4.2.10.1/install.sh 2009-06-18 13:16:31.000000000 -0700
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ #
+
+-VERSION=4.2.10
++VERSION=4.2.10.1
+
+ usage() # $1 = exit status
+ {
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/releasenotes.txt shorewall-perl-4.2.10.1/releasenotes.txt
+--- shorewall-perl-4.2.10/releasenotes.txt 2009-06-18 07:04:06.000000000 -0700
++++ shorewall-perl-4.2.10.1/releasenotes.txt 2009-06-18 13:22:33.000000000 -0700
+@@ -1,4 +1,4 @@
+-Shorewall 4.2.10
++Shorewall 4.2.10 Patch release 1
+
+ ----------------------------------------------------------------------------
+ R E L E A S E 4 . 2 H I G H L I G H T S
+@@ -27,6 +27,14 @@
+ - Perl 5.10 if you wish to use DNS names in your IPv6 config files.
+ In that case you will also have to install Perl Socket6 support.
+
++Problems corrected in Shorewall-perl 4.2.10.1
++
++1) Users that set TC_ENABLED=Internal and have entries in
++ /etc/shorewall/tcdevices and /etc/shorewall/tcclasses may experience
++ startup error such as the following:
++
++ ERROR: Command "tc qdisc add dev eth1 root handle 1: htb default 12 r2q 20.8" Failed
++
+ Problems corrected in Shorewall 4.2.10
+
+ 1) A 'large quantum' warning log message during restart has been
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/Shorewall/Config.pm shorewall-perl-4.2.10.1/Shorewall/Config.pm
+--- shorewall-perl-4.2.10/Shorewall/Config.pm 2009-05-29 18:34:08.000000000 -0700
++++ shorewall-perl-4.2.10.1/Shorewall/Config.pm 2009-06-18 13:16:31.000000000 -0700
+@@ -312,7 +312,7 @@
+ TC_SCRIPT => '',
+ EXPORT => 0,
+ UNTRACKED => 0,
+- VERSION => "4.2.10",
++ VERSION => "4.2.10.1",
+ CAPVERSION => 40205 ,
+ );
+
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/Shorewall/Tc.pm shorewall-perl-4.2.10.1/Shorewall/Tc.pm
+--- shorewall-perl-4.2.10/Shorewall/Tc.pm 2009-05-23 08:58:07.000000000 -0700
++++ shorewall-perl-4.2.10.1/Shorewall/Tc.pm 2009-06-18 13:11:28.000000000 -0700
+@@ -787,7 +787,7 @@
+ my $devref = $tcdevices{$device};
+ my $defmark = $devref->{default} || 0;
+ my $devnum = $devref->{number};
+- my $r2q = calculate_r2q $devref->{out_bandwidth};
++ my $r2q = int calculate_r2q $devref->{out_bandwidth};
+
+ emit "if interface_is_up $device; then";
+
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/shorewall-perl.spec shorewall-perl-4.2.10.1/shorewall-perl.spec
+--- shorewall-perl-4.2.10/shorewall-perl.spec 2009-05-29 18:34:08.000000000 -0700
++++ shorewall-perl-4.2.10.1/shorewall-perl.spec 2009-06-18 13:16:31.000000000 -0700
+@@ -1,6 +1,6 @@
+ %define name shorewall-perl
+ %define version 4.2.10
+-%define release 0base
++%define release 1
+
+ Summary: Shoreline Firewall Perl-based compiler.
+ Name: %{name}
+@@ -62,6 +62,8 @@
+ %doc COPYING releasenotes.txt
+
+ %changelog
++* Thu Jun 18 2009 Tom Eastep tom@shorewall.net
++- Updated to 4.2.10-1
+ * Fri May 29 2009 Tom Eastep tom@shorewall.net
+ - Updated to 4.2.10-0base
+ * Thu May 07 2009 Tom Eastep tom@shorewall.net
diff --git a/network/shorewall-perl/shorewall-perl.SlackBuild b/network/shorewall-perl/shorewall-perl.SlackBuild
new file mode 100644
index 000000000000..d095b20d3da4
--- /dev/null
+++ b/network/shorewall-perl/shorewall-perl.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for shorewall-perl
+
+# Copyright (c) 2008-2009 Gregory J.L. Tourte (artourter@gmail.com)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=shorewall-perl
+VERSION=${VERSION:-4.2.10.1}
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+BASEVERS=4.2.10
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$BASEVERS
+tar xvf $CWD/$PRGNAM-$BASEVERS.tar.bz2
+cd $TMP/$PRGNAM-$BASEVERS
+chown -R root:root .
+
+# patching the base against all the patchlevel patches in order, if available
+if [ $(ls $CWD/patches 2>/dev/null | wc -l) -gt 0 ]; then
+ for PATCH in $CWD/patches/* ; do
+ patch -p1 < $PATCH
+ done
+fi
+
+PREFIX=$PKG \
+ OWNER='root' \
+ GROUP='root' \
+ DEST=/etc/rc.d \
+ SLACKWARE=yes \
+ ./install.sh
+
+chmod 0755 $PKG/usr/share/shorewall-perl
+
+# cleaning up empty directories
+rm -rf $PKG/sbin $PKG/etc
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.txt changelog.txt releasenotes.txt COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+#cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+
+# Clean up the extra stuff:
+if [ "$1" = "--cleanup" ]; then
+ rm -rf $TMP/$PRGNAM-$BASEVERS
+ rm -rf $PKG
+fi
+
+# vim: et ts=2
diff --git a/network/shorewall-perl/shorewall-perl.info b/network/shorewall-perl/shorewall-perl.info
new file mode 100644
index 000000000000..f5fcd1bef6f0
--- /dev/null
+++ b/network/shorewall-perl/shorewall-perl.info
@@ -0,0 +1,8 @@
+PRGNAM="shorewall-perl"
+VERSION="4.2.10.1"
+HOMEPAGE="http://www.shorewall.net"
+DOWNLOAD="http://www.shorewall.net/pub/shorewall/4.2/shorewall-4.2.10/base/shorewall-perl-4.2.10.tar.bz2"
+MD5SUM="0305da84040ae121b96743c2a7e711e9"
+MAINTAINER="ArTourter"
+EMAIL="artourter@gmail.com"
+APPROVED="rworkman"
diff --git a/network/shorewall-perl/slack-desc b/network/shorewall-perl/slack-desc
new file mode 100644
index 000000000000..6cf66d154c11
--- /dev/null
+++ b/network/shorewall-perl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+shorewall-perl: Shorewall-Perl (Perl-based compiler for Shoreline Firewall)
+shorewall-perl:
+shorewall-perl: The Shoreline Firewall, more commonly known as "Shorewall", is a
+shorewall-perl: Netfilter (iptables) based firewall that can be used on a dedicated
+shorewall-perl: firewall system, a multi-function gateway/router/server or on a
+shorewall-perl: standalone GNU/Linux system.
+shorewall-perl:
+shorewall-perl: This is the perl compiler part of Shorewall that allows faster
+shorewall-perl: compilation and execution than the legacy shorewall-shell compiler
+shorewall-perl:
+shorewall-perl: http://www.shorewall.net/