aboutsummaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2022-03-01 04:34:06 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-01 19:35:39 +0700
commite578d88b12aab83bd95c4ec017c69bf18d68880d (patch)
tree0f15cab8aa187114f117c3bff686a709a44ff934 /network
parentc4c5f91d9076c85e537753c4580407cb89024504 (diff)
downloadslackbuilds-e578d88b12aab83bd95c4ec017c69bf18d68880d.tar.xz
network/iptv-analyzer: Removed.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/iptv-analyzer/README8
-rw-r--r--network/iptv-analyzer/doinst.sh3
-rw-r--r--network/iptv-analyzer/iptv-analyzer.SlackBuild152
-rw-r--r--network/iptv-analyzer/iptv-analyzer.info10
-rw-r--r--network/iptv-analyzer/patches/Makefile.am.diff13
-rw-r--r--network/iptv-analyzer/patches/Makefile.in.diff11
-rw-r--r--network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch41
-rw-r--r--network/iptv-analyzer/patches/kernel-4.4.diff81
-rw-r--r--network/iptv-analyzer/slack-desc19
9 files changed, 0 insertions, 338 deletions
diff --git a/network/iptv-analyzer/README b/network/iptv-analyzer/README
deleted file mode 100644
index 4388448340a3..000000000000
--- a/network/iptv-analyzer/README
+++ /dev/null
@@ -1,8 +0,0 @@
-The IPTV-Analyzer is a continuous/real-time tool for analyzing the contents
-of MPEG2 Transport Stream (TS) packets, which is commonly used for IPTV
-multicast signals.
-
-The main purpose is continuous quality measurement, with a focus on detecting
-MPEG2 TS/CC packet drops.
-
-It scales to hundreds of IPTV channels, even on small ATOM based CPUs.
diff --git a/network/iptv-analyzer/doinst.sh b/network/iptv-analyzer/doinst.sh
deleted file mode 100644
index a4258c7da6e3..000000000000
--- a/network/iptv-analyzer/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x sbin/depmod ]; then
- chroot . /sbin/depmod -a @@KERNEL@@ >/dev/null 2>&1
-fi
diff --git a/network/iptv-analyzer/iptv-analyzer.SlackBuild b/network/iptv-analyzer/iptv-analyzer.SlackBuild
deleted file mode 100644
index 52f459d6e252..000000000000
--- a/network/iptv-analyzer/iptv-analyzer.SlackBuild
+++ /dev/null
@@ -1,152 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for iptv-analyzer
-
-# Copyright 2013, 2015, 2016, 2017 Mario Preksavec, Zagreb, Croatia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=iptv-analyzer
-VERSION=${VERSION:-0.9.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=IPTV-Analyzer
-KERNEL=${KERNEL:-$( uname -r )}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-${VERSION}_${KERNEL//-/_}-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p1 <$CWD/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch
-patch -p1 <$CWD/patches/kernel-4.4.diff
-patch -p1 <$CWD/patches/Makefile.am.diff
-patch -p1 <$CWD/patches/Makefile.in.diff
-
-./autogen.sh
-
-mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/xtables
-
-env -u ARCH \
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --datarootdir=/usr \
- --with-xtlibdir=$PKG/usr/lib${LIBDIRSUFFIX}/xtables \
- --with-kbuild=/lib/modules/$KERNEL/build \
- --build=$ARCH-slackware-linux
-
-env -u ARCH make
-env -u ARCH make install DESTDIR=$PKG \
- INSTALLDIRS=vendor \
- INST_ETC=$PKG/etc/$PRGNAM \
- INSTALL_MOD_PATH=$PKG
-
-# Module installer was too leaky
-mkdir -p $PKG/lib/modules/$KERNEL/extra
-cp -a iptables-module/{compat_xtables,xt_mpeg2ts}.ko \
- $PKG/lib/modules/$KERNEL/extra
-
-# Manpages are a bit stubborn
-mv $PKG/usr/share/man $PKG/usr
-
-# Fonts are elsewhere
-sed -i 's#usr/share/fonts/truetype/freefont#usr/share/fonts/TTF#' \
- webfrontend/www/{graphs.inc.php,staging/pie01.php}
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
-
-# Remove empty directories
-find $PKG -depth -type d -empty -delete || true
-
-# Remove git cruft
-find $PKG -type f -name .gitignore -delete
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING ChangeLog INSTALL README.wiki TODO database doc/* \
- collector/bin/generate-test-snmptrap.pl webfrontend $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a snmp/mibs $PKG/usr/doc/$PRGNAM-$VERSION/snmp-mibs
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-sed -e "s:@@KERNEL@@:$KERNEL:" $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_${KERNEL//-/_}-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/iptv-analyzer/iptv-analyzer.info b/network/iptv-analyzer/iptv-analyzer.info
deleted file mode 100644
index 3b55c729fe52..000000000000
--- a/network/iptv-analyzer/iptv-analyzer.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="iptv-analyzer"
-VERSION="0.9.4"
-HOMEPAGE="https://github.com/netoptimizer/IPTV-Analyzer/"
-DOWNLOAD="https://github.com/netoptimizer/IPTV-Analyzer/archive/v0.9.4/IPTV-Analyzer-0.9.4.tar.gz"
-MD5SUM="b1c307eb8c0afe846d53b901386b3453"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="perl-Config-File perl-Data-Compare perl-Log-Dispatch perl-Log-Log4perl perl-Net-SNMP perl-Proc-Daemon perl-Proc-PID-File"
-MAINTAINER="Mario Preksavec"
-EMAIL="mario at slackware dot hr"
diff --git a/network/iptv-analyzer/patches/Makefile.am.diff b/network/iptv-analyzer/patches/Makefile.am.diff
deleted file mode 100644
index 8e03aab10ee5..000000000000
--- a/network/iptv-analyzer/patches/Makefile.am.diff
+++ /dev/null
@@ -1,13 +0,0 @@
---- IPTV-Analyzer-0.9.4/Makefile.am.orig 2015-03-04 10:41:03.000000000 +0100
-+++ IPTV-Analyzer-0.9.4/Makefile.am 2017-11-05 00:20:05.903209784 +0100
-@@ -21,8 +21,8 @@
- #xtables-addons.8: FORCE
- # ${MAKE} -f Makefile.mans all;
-
--install-exec-hook:
-- depmod -a || :;
-+#install-exec-hook:
-+# depmod -a || :;
-
- #config.status: Makefile.iptrules.in
-
diff --git a/network/iptv-analyzer/patches/Makefile.in.diff b/network/iptv-analyzer/patches/Makefile.in.diff
deleted file mode 100644
index f0c93e492d99..000000000000
--- a/network/iptv-analyzer/patches/Makefile.in.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- IPTV-Analyzer-0.9.4/iptables-module/Makefile.in.orig 2015-03-04 10:41:03.000000000 +0100
-+++ IPTV-Analyzer-0.9.4/iptables-module/Makefile.in 2017-11-05 03:37:21.671512778 +0100
-@@ -115,7 +115,7 @@
- exit 2; \
- fi
-
--install: lib_install modules_install
-+install: lib_install modules
-
-
- clean:
diff --git a/network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch b/network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch
deleted file mode 100644
index 4a84020a1e0b..000000000000
--- a/network/iptv-analyzer/patches/e5d7c0b90cfe3218d67b56e122140456206f6a65.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From e5d7c0b90cfe3218d67b56e122140456206f6a65 Mon Sep 17 00:00:00 2001
-From: Hoai-Thu Vuong <thuvh87@gmail.com>
-Date: Tue, 12 Jan 2016 17:30:45 +0700
-Subject: [PATCH] using echo and tag php in code
-
----
- webfrontend/www/design.inc.php | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/webfrontend/www/design.inc.php b/webfrontend/www/design.inc.php
-index 174e04a..9fcd7b0 100644
---- a/webfrontend/www/design.inc.php
-+++ b/webfrontend/www/design.inc.php
-@@ -29,12 +29,12 @@ function doHeader($title="", $options=FALSE) {
- <meta name="description" content="tvprobe webfrontend" />
- <meta name="publisher" content="ComX Networks A/S" />
-
-- <link rel="stylesheet" type="text/css" href="<?=$incdir?>css/motorola.css">
-+ <link rel="stylesheet" type="text/css" href="<?php echo $incdir; ?>css/motorola.css">
- <?php
- if ($include_javascript == TRUE) {
- ?>
- <script
-- src="<?=$incdir?>functions.js" type="text/javascript" language='javascript'>
-+ src="<?php echo $incdir; ?>functions.js" type="text/javascript" language='javascript'>
- </script>
- <?php
- }
-@@ -44,10 +44,10 @@ function doHeader($title="", $options=FALSE) {
- ?>
- <!--Epoch's styles-->
- <link rel="stylesheet" type="text/css"
-- href="<?=$incdir?>js/epoch_v202_en/epoch_styles.css" />
-+ href="<?php echo $incdir; ?>js/epoch_v202_en/epoch_styles.css" />
-
- <!--Epoch's Code-->
-- <script type="text/javascript" src="<?=$incdir?>js/epoch_v202_en/epoch_classes.js">
-+ <script type="text/javascript" src="<?php echo $incdir; ?>js/epoch_v202_en/epoch_classes.js">
- </script>
-
- <script type="text/javascript">
diff --git a/network/iptv-analyzer/patches/kernel-4.4.diff b/network/iptv-analyzer/patches/kernel-4.4.diff
deleted file mode 100644
index 471305bd4f7b..000000000000
--- a/network/iptv-analyzer/patches/kernel-4.4.diff
+++ /dev/null
@@ -1,81 +0,0 @@
-diff --git a/iptables-module/compat_xtables.c b/iptables-module/compat_xtables.c
-index c5b67a4..40f83c8 100644
---- a/iptables-module/compat_xtables.c
-+++ b/iptables-module/compat_xtables.c
-@@ -464,6 +464,7 @@ struct xt_match *xtnu_request_find_match(unsigned int af, const char *name,
- }
- EXPORT_SYMBOL_GPL(xtnu_request_find_match);
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 4, 0)
- int xtnu_ip_route_me_harder(struct sk_buff **pskb, unsigned int addr_type)
- {
- #if LINUX_VERSION_CODE <= KERNEL_VERSION(2, 6, 17)
-@@ -476,6 +477,7 @@ int xtnu_ip_route_me_harder(struct sk_buff **pskb, unsigned int addr_type)
- #endif
- }
- EXPORT_SYMBOL_GPL(xtnu_ip_route_me_harder);
-+#endif
-
- int xtnu_skb_make_writable(struct sk_buff **pskb, unsigned int len)
- {
-diff --git a/iptables-module/compat_xtnu.h b/iptables-module/compat_xtnu.h
-index 02b6575..253e3df 100644
---- a/iptables-module/compat_xtnu.h
-+++ b/iptables-module/compat_xtnu.h
-@@ -143,7 +143,9 @@ static inline __wsum csum_unfold(__sum16 n)
- #endif
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 4, 0)
- extern int xtnu_ip_local_out(struct sk_buff *);
- extern int xtnu_ip_route_me_harder(struct sk_buff **, unsigned int);
-+#endif
- extern int xtnu_skb_make_writable(struct sk_buff **, unsigned int);
- extern int xtnu_register_match(struct xtnu_match *);
- extern int xtnu_ip_route_output_key(void *, struct rtable **, struct flowi *);
-diff --git a/iptables-module/xt_mpeg2ts.c b/iptables-module/xt_mpeg2ts.c
-index 91ae4a0..87cfb17 100644
---- a/iptables-module/xt_mpeg2ts.c
-+++ b/iptables-module/xt_mpeg2ts.c
-@@ -99,7 +99,7 @@ static const struct file_operations dl_file_ops;
- #endif
-
- static int debug = -1;
--static int msg_level;
-+static int msg_level = MPEG2TS_MSG_DEFAULT;
- module_param(debug, int, 0);
- module_param(msg_level, int, 0664);
- MODULE_PARM_DESC(debug, "Set low N bits of message level");
-@@ -1299,14 +1299,12 @@ static void mpeg2ts_seq_stop(struct seq_file *s, void *v)
- static int mpeg2ts_seq_show_real(struct mpeg2ts_stream *stream,
- struct seq_file *s, unsigned int bucket)
- {
-- int res;
--
- if (!atomic_inc_not_zero(&stream->use)) {
- /* If "use" is zero, then we about to be free'd */
- return 0;
- }
-
-- res = seq_printf(s, "bucket:%d dst:%pI4 src:%pI4 dport:%u sport:%u "
-+ seq_printf(s, "bucket:%d dst:%pI4 src:%pI4 dport:%u sport:%u "
- "pids:%d skips:%llu discontinuity:%llu "
- "payload_bytes:%llu packets:%llu\n",
- bucket,
-@@ -1323,7 +1321,7 @@ static int mpeg2ts_seq_show_real(struct mpeg2ts_stream *stream,
-
- atomic_dec(&stream->use);
-
-- return res;
-+ return seq_has_overflowed(s);
- }
-
- static int mpeg2ts_seq_show(struct seq_file *s, void *v)
-@@ -1434,7 +1432,7 @@ static int __init mpeg2ts_mt_init(void)
- */
- INIT_LIST_HEAD(&conn_htables);
-
-- msg_level = netif_msg_init(debug, MPEG2TS_MSG_DEFAULT);
-+ msg_level = netif_msg_init(debug, msg_level);
- msg_info(DRV, "Loading: %s", version);
- msg_dbg(DRV, "Message level (msg_level): 0x%X", msg_level);
-
diff --git a/network/iptv-analyzer/slack-desc b/network/iptv-analyzer/slack-desc
deleted file mode 100644
index 6c7511834e7a..000000000000
--- a/network/iptv-analyzer/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-iptv-analyzer: iptv-analyzer (IPTV MPEG2 Transport Stream Analyzer)
-iptv-analyzer:
-iptv-analyzer: The IPTV-Analyzer is a continuous/real-time tool for analyzing the
-iptv-analyzer: contents of MPEG2 Transport Stream (TS) packets, which is commonly
-iptv-analyzer: used for IPTV multicast signals. The main purpose is continuous
-iptv-analyzer: quality measurement, with a focus on detecting MPEG2 TS/CC packet
-iptv-analyzer: drops.
-iptv-analyzer:
-iptv-analyzer: Homepage: https://github.com/netoptimizer/IPTV-Analyzer/
-iptv-analyzer:
-iptv-analyzer: