aboutsummaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
authorJay Lanagan <1995739+mac-a-r0ni@users.noreply.github.com>2023-10-10 02:09:34 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-11 22:27:01 +0700
commitb0e010952a67a464807c82a0e4a530dfbd7f340b (patch)
tree5ddfdc5928ea029ec8e7371ef4cf08fb6516fc6a /network
parent519bc592f6a0b5796d10b9090c972e45b68ea828 (diff)
network/gui-ufw: Updated for version 22.04.0
deserted script, new maintainer & update Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/gui-ufw/gufw-open.diff10
-rw-r--r--network/gui-ufw/gufw.wrapper18
-rw-r--r--network/gui-ufw/gui-ufw.SlackBuild94
-rw-r--r--network/gui-ufw/gui-ufw.info14
-rw-r--r--network/gui-ufw/path-fix.diff16
5 files changed, 88 insertions, 64 deletions
diff --git a/network/gui-ufw/gufw-open.diff b/network/gui-ufw/gufw-open.diff
new file mode 100644
index 000000000000..e972d8b9218b
--- /dev/null
+++ b/network/gui-ufw/gufw-open.diff
@@ -0,0 +1,10 @@
+--- a/bin/gufw
++++ b/bin/gufw
+@@ -1,3 +1,6 @@
+ #!/bin/bash
++if [ $(loginctl show-session $(loginctl|grep $(whoami) |awk '{print $1}') -p Type) = "Type=wayland" ]; then
++ xhost +si:localuser:root
++fi
+ c_user=$(whoami)
+ pkexec gufw-pkexec $c_user
+
diff --git a/network/gui-ufw/gufw.wrapper b/network/gui-ufw/gufw.wrapper
deleted file mode 100644
index b5eedf591bb2..000000000000
--- a/network/gui-ufw/gufw.wrapper
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/bash
-
-# 20220315 bkw: replacement wrapper script for gui-ufw, part of the
-# gui-ufw SlackBuilds.org build, by B. Watson. WTFPL licensed.
-
-# find the path to the script, in a way that won't break if the
-# python version gets upgraded, and works on either 32-bit or 64-bit
-# Slackware.
-PYVER="$( python3 --version | cut -d' ' -f2 | cut -d. -f1,2 )"
-for i in lib64 lib; do
- dir="/usr/$i/python$PYVER/site-packages/gufw"
- [ -d "$dir" ] && break
-done
-
-# kdesu takes care of allowing access to the X server (no need for
-# xhost commands) and works fine regardless of desktop environment or
-# window manager. it doesn't rely on policykit, which is a nice bonus.
-exec kdesu -c "python3 $dir/gufw.py"
diff --git a/network/gui-ufw/gui-ufw.SlackBuild b/network/gui-ufw/gui-ufw.SlackBuild
index 306d92af576e..caeda2c4ae1f 100644
--- a/network/gui-ufw/gui-ufw.SlackBuild
+++ b/network/gui-ufw/gui-ufw.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for gui-ufw
-# Copyright 2018, 2019 Skaendo <skaendo@linuxmail.org>
+# Copyright 2022-23 Jay Lanagan (j@lngn.net), Detroit, MI, USA
+# Previous script by Skaendo w/ bkw patches, this replaces it.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -11,28 +12,22 @@
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20220315 bkw: Modified by SlackBuilds.org, BUILD=2:
-# - fix broken wrapper scripts that prevented the app from starting
-# on 32-bit Slackware, or after a python3 upgrade, or if the user
-# uses runlevel 3.
-# - fix repeated builds (we were missing "rm -rf $PRGNAM-$VERSION").
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gui-ufw
-VERSION=${VERSION:-19.10.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-22.04.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -52,9 +47,22 @@ fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-
-# 20220315 bkw: No compiled code here, and setup.py knows about
-# lib64 directories already.
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
set -e
@@ -62,28 +70,20 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-mkdir $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG
+# path & opening app fixes from ubuntu
+patch -p1 < $CWD/gufw-open.diff
+patch -p1 < $CWD/path-fix.diff
-# 20220315 bkw: upstream's wrapper scripts are broken in multiple ways:
-# - hardcoded (wrong) path to gufw.py
-# - relies on loginctl, meaning it'll never work for users who
-# use runlevel 3 (console login + startx)
-# - the xhost stuff unconditionally removes localuser:root access
-# when gufw exits, even if the user put it there before the
-# script was run
-# Replace gufw and gufw-pkexec with something that actually works.
-rm -f $PKG/usr/bin/*
-install -oroot -groot -m0755 $CWD/gufw.wrapper $PKG/usr/bin/gufw
+python3 setup.py install --prefix=/usr --root=$PKG
# Move the manpage to a sane directory.
mv $PKG/usr/share/man $PKG/usr
@@ -91,7 +91,23 @@ mv $PKG/usr/share/man $PKG/usr
# Clean up some duplicates
rm -rf $PKG/usr/share/doc
-gzip -9 $PKG/usr/man/man*/*
+# Compress and link manpages, if any:
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ for manpagedir in $(find . -type d -name "man*") ; do
+ ( cd $manpagedir
+ for eachpage in $( find . -type l -maxdepth 1) ; do
+ ln -s $( readlink $eachpage ).gz $eachpage.gz
+ rm $eachpage
+ done
+ gzip -9 *.*
+ )
+ done
+ )
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING* README \
@@ -99,8 +115,8 @@ cp -a COPYING* README \
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/gui-ufw/gui-ufw.info b/network/gui-ufw/gui-ufw.info
index cb67c32ac9a6..978a11ceaf8f 100644
--- a/network/gui-ufw/gui-ufw.info
+++ b/network/gui-ufw/gui-ufw.info
@@ -1,10 +1,10 @@
PRGNAM="gui-ufw"
-VERSION="19.10.0"
-HOMEPAGE="https://gufw.org/"
-DOWNLOAD="https://launchpad.net/gui-ufw/trunk/19.10/+download/gui-ufw-19.10.0.tar.gz"
-MD5SUM="46ba50d59dfa96e36d04ab2f21fc2d21"
+VERSION="22.04.0"
+HOMEPAGE="https://github.com/costales/gufw"
+DOWNLOAD="https://github.com/costales/gufw/releases/download/22.04/gui-ufw-22.04.0.tar.gz"
+MD5SUM="8a10f6957b38b569a82843e1276c1a50"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-distutils-extra ufw webkit2gtk"
-MAINTAINER="Skaendo"
-EMAIL="skaendo@linuxmail.org"
+REQUIRES="python-distutils-extra webkit2gtk ufw"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/network/gui-ufw/path-fix.diff b/network/gui-ufw/path-fix.diff
new file mode 100644
index 000000000000..2ebfdb0c21c3
--- /dev/null
+++ b/network/gui-ufw/path-fix.diff
@@ -0,0 +1,16 @@
+--- a/bin/gufw-pkexec
++++ b/bin/gufw-pkexec
+@@ -1,2 +1,11 @@
+ #!/bin/bash
+-python3 /usr/share/gufw/gufw/gufw.py $1
++LOCATIONS=`ls -ld /usr/lib*/python*/site-packages/gufw/gufw.py | awk '{print $9}'` # from source
++LOCATIONS=( "${LOCATIONS[@]}" "/usr/share/gufw/gufw/gufw.py" ) # deb package
++
++for ((i = 0; i < ${#LOCATIONS[@]}; i++))
++do
++ if [[ -e "${LOCATIONS[${i}]}" ]]; then
++ python3 ${LOCATIONS[${i}]} $1
++ fi
++done
++
+