aboutsummaryrefslogtreecommitdiff
path: root/network/ufw
diff options
context:
space:
mode:
authorJay Lanagan <j@lngn.net>2023-09-21 22:42:59 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-23 08:42:56 +0700
commit5b5e1ea07db92534c05bf5c18ef37de50148a38d (patch)
treeef7906dad77c1e6d6e082a2bbc99135c52b8646a /network/ufw
parentdceb0f34f8b534b817a7d51e353209ec7bcb049c (diff)
network/ufw: Updated for version 0.36.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/ufw')
-rw-r--r--network/ufw/ufw.SlackBuild47
-rw-r--r--network/ufw/ufw.conf.patch5
-rw-r--r--network/ufw/ufw.info10
3 files changed, 28 insertions, 34 deletions
diff --git a/network/ufw/ufw.SlackBuild b/network/ufw/ufw.SlackBuild
index 9915b8daa1356..f3b65a2a135d0 100644
--- a/network/ufw/ufw.SlackBuild
+++ b/network/ufw/ufw.SlackBuild
@@ -6,6 +6,7 @@
# Copyright 2013 Ricardson Williams <ricardsonwilliams@gmail.com>
# Copyright 2014-2015 Rodolfo Gouveia <rgouveia@cosmico.net>
# Copyright 2016 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2023 Jay Lanagan <j@lngn.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ufw
-VERSION=${VERSION:-0.36}
+VERSION=${VERSION:-0.36.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -83,22 +67,31 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 --verbose < $CWD/ufw.conf.patch
-patch -p1 --verbose < $CWD/ufw-0.35-fix-iptables-path.patch
-
-# Python3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mv $PKG/usr/share/man $PKG/usr/man
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+# Compress and link manpages, if any:
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ for manpagedir in $(find . -type d -name "man*") ; do
+ ( cd $manpagedir
+ for eachpage in $( find . -type l -maxdepth 1) ; do
+ ln -s $( readlink $eachpage ).gz $eachpage.gz
+ rm $eachpage
+ done
+ gzip -9 *.*
+ )
+ done
+ )
+fi
+
+mkdir -p $PKG/etc/rc.d
+cat $TMP/$PRGNAM-$VERSION/doc/initscript.example > $PKG/etc/rc.d/rc.ufw
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog* COPYING README* TODO doc/*.example $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/network/ufw/ufw.conf.patch b/network/ufw/ufw.conf.patch
index 0b085ae82b591..eda9b184e1ac5 100644
--- a/network/ufw/ufw.conf.patch
+++ b/network/ufw/ufw.conf.patch
@@ -1,5 +1,5 @@
---- ufw-0.33.orig/conf/ufw.conf 2012-08-18 05:12:49.000000000 +0800
-+++ ufw-0.33/conf/ufw.conf 2013-07-16 04:18:44.365425697 +0800
+--- a/conf/ufw.conf
++++ b/conf/ufw.conf
@@ -3,7 +3,7 @@
# Set to yes to start on boot. If setting this remotely, be sure to add a rule
@@ -9,3 +9,4 @@
# Please use the 'ufw' command to set the loglevel. Eg: 'ufw logging medium'.
# See 'man ufw' for details.
+
diff --git a/network/ufw/ufw.info b/network/ufw/ufw.info
index 1d396dca15f35..b2d57c2680241 100644
--- a/network/ufw/ufw.info
+++ b/network/ufw/ufw.info
@@ -1,10 +1,10 @@
PRGNAM="ufw"
-VERSION="0.36"
+VERSION="0.36.2"
HOMEPAGE="https://launchpad.net/ufw"
-DOWNLOAD="https://launchpad.net/ufw/0.36/0.36/+download/ufw-0.36.tar.gz"
-MD5SUM="6d8ab1506da21ae003f4628f93d05781"
+DOWNLOAD="https://launchpad.net/ufw/0.36/0.36.2/+download/ufw-0.36.2.tar.gz"
+MD5SUM="4a1c52b7da2b25e66e91b5f16a7d032d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"