aboutsummaryrefslogtreecommitdiff
path: root/network/toot
diff options
context:
space:
mode:
authorKevin Bryant <sultmhoor+SB@gmail.com>2022-12-15 15:58:04 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-17 09:13:54 +0700
commit0f28b3db5e6ba9462428473babdb4669fa8f9a73 (patch)
tree533130b6af9f130b239ccd2e5ce16b2385606391 /network/toot
parent243b00c2506e6b4c648f190186d515d870f56f43 (diff)
downloadslackbuilds-0f28b3db5e6ba9462428473babdb4669fa8f9a73.tar.xz
network/toot: Updated for version 0.32.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/toot')
-rw-r--r--network/toot/toot.SlackBuild15
-rw-r--r--network/toot/toot.info6
2 files changed, 17 insertions, 4 deletions
diff --git a/network/toot/toot.SlackBuild b/network/toot/toot.SlackBuild
index 9d87437fa13c..23bc82ac3808 100644
--- a/network/toot/toot.SlackBuild
+++ b/network/toot/toot.SlackBuild
@@ -25,13 +25,16 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=toot
-VERSION=${VERSION:-0.30.1}
+VERSION=${VERSION:-0.32.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=${ARCH:-noarch}
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -58,17 +61,27 @@ find -L . \
python3 setup.py install --root=$PKG
+# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# If the man pages are installed to /usr/share/man instead, you'll need to
+# move them manually.
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+# Also, include the SlackBuild script in the documentation directory
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+# cp -a \
+# $TMP/$PRGNAM-$VERSION/docs/ \
+# $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+# If package symlinks need to be created during install *before*
+# your custom contents of doinst.sh runs, then add the -p switch to
+# the makepkg command below -- see makepkg(8) for details
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/toot/toot.info b/network/toot/toot.info
index e3d159e69e70..0446fdeedcd2 100644
--- a/network/toot/toot.info
+++ b/network/toot/toot.info
@@ -1,8 +1,8 @@
PRGNAM="toot"
-VERSION="0.30.1"
+VERSION="0.32.1"
HOMEPAGE="https://github.com/ihabunek/toot"
-DOWNLOAD="https://github.com/ihabunek/toot/releases/download/0.30.1/toot-0.30.1.tar.gz"
-MD5SUM="d7d6ee286b65b8f072eb4aa27862c753"
+DOWNLOAD="https://github.com/ihabunek/toot/releases/download/0.32.1/toot-0.32.1.tar.gz"
+MD5SUM="1755ad08df7b60c472a3ee20f6a1063e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="BeautifulSoup4 python3-wcwidth python-urwid"