aboutsummaryrefslogtreecommitdiff
path: root/network/jigdo/jigdo.SlackBuild
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2022-03-01 12:58:26 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-03 15:56:41 +0700
commit37fcce65bd5c97cfc83dab0bc34fdbdcbc03cb52 (patch)
treef8e3364d5e91c3aceaa05d385de6da003a47c23d /network/jigdo/jigdo.SlackBuild
parent6eacdafa4476e49f7a3f446088b2acfa52a0ebc6 (diff)
downloadslackbuilds-37fcce65bd5c97cfc83dab0bc34fdbdcbc03cb52.tar.xz
network/jigdo: Updated for version 0.8.1.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/jigdo/jigdo.SlackBuild')
-rw-r--r--network/jigdo/jigdo.SlackBuild57
1 files changed, 32 insertions, 25 deletions
diff --git a/network/jigdo/jigdo.SlackBuild b/network/jigdo/jigdo.SlackBuild
index 68572c5ee7e7..c5939333f029 100644
--- a/network/jigdo/jigdo.SlackBuild
+++ b/network/jigdo/jigdo.SlackBuild
@@ -21,25 +21,26 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220222 bkw: Modified by SlackBuilds.org: fix build on 15.0.
+# - update for v0.8.1, which was released in 2021. the old version
+# was from 2009...
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jigdo
-VERSION=${VERSION:-0.7.3}
+VERSION=${VERSION:-0.8.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -49,8 +50,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -63,7 +64,6 @@ else
LIBDIRSUFFIX=""
fi
-DOCS="README THANKS changelog doc/TechDetails.txt doc/Hacking.txt"
set -e
@@ -71,20 +71,24 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# apply some patches from debian
-zcat $CWD/jigdo_0.7.3-3.diff.gz | patch -p1
-
-# Fic for gcc-7.x, thanks fedora!
-patch -p1 < $CWD/jigdo-0.7.3-gcc7.patch
+ -exec chmod 644 {} \+
+
+# 20220301 bkw: doc/Makefile.in has some confusing looking stuff that
+# didn't work properly. It would work with some version of docbook2man
+# (one that doesn't print "Working on <file>" on stdout, and does
+# print whatever the sed stuff was expecting to see). There's a much
+# cleaner way to do it, using make's $(subst) macro. Also, don't try
+# to build debian-jigdo-mini-howto.html because it's for some other
+# version of docbook2man. I took the built HTML file from a Debian
+# package and made it a separate download.
+patch -p1 < $CWD/fix_man_page_build.diff
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -97,17 +101,20 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+strip $PKG/usr/bin/$PRGNAM-file
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220301 bkw: man pages get installed +x, sigh.
+chmod 644 $PKG/usr/man/man*/*
+gzip -9 $PKG/usr/man/man*/*
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+DOCS="COPYING README THANKS changelog doc/TechDetails.txt doc/Hacking.txt"
+HOWTO="debian-jigdo-mini-howto.html"
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-mv $PKG/usr/share/$PRGNAM/COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a $DOCS $PKGDOC
+zcat $CWD/$HOWTO.gz > $PKGDOC/$HOWTO
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc