aboutsummaryrefslogtreecommitdiff
path: root/network/dillo/dillo-3.0.5-openssl-1.1.patch
diff options
context:
space:
mode:
authorRuben Schuller <sb@rbn.im>2021-04-17 16:05:33 +0200
committerRobby Workman <rworkman@slackbuilds.org>2021-04-17 23:18:56 -0500
commit1152660bd586f47d3cdb6f9ba1fa552178e7b4ca (patch)
tree3ec014c0d5aa516eae218caab2dc2230ddbe0625 /network/dillo/dillo-3.0.5-openssl-1.1.patch
parent40761f4e35540d3f96908791aa181a4e59ec4d50 (diff)
network/dillo: Patched for openssl >= 1.1.x and gcc >= 10.x.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network/dillo/dillo-3.0.5-openssl-1.1.patch')
-rw-r--r--network/dillo/dillo-3.0.5-openssl-1.1.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/network/dillo/dillo-3.0.5-openssl-1.1.patch b/network/dillo/dillo-3.0.5-openssl-1.1.patch
new file mode 100644
index 0000000000000..f21694113c2bd
--- /dev/null
+++ b/network/dillo/dillo-3.0.5-openssl-1.1.patch
@@ -0,0 +1,26 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -286,7 +286,7 @@
+
+ if test "x$ssl_ok" = "xyes"; then
+ old_libs="$LIBS"
+- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
++ AC_CHECK_LIB(ssl, OPENSSL_config, ssl_ok=yes, ssl_ok=no, -lcrypto)
+ LIBS="$old_libs"
+ fi
+
+--- a/dpi/https.c
++++ b/dpi/https.c
+@@ -476,7 +476,11 @@
+ case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
+ /*Either self signed and untrusted*/
+ /*Extract CN from certificate name information*/
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
++#else
++ if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
++#endif
+ strcpy(buf, "(no CN given)");
+ } else {
+ char *cn_end;
+