aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2024-08-27 17:21:51 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-31 07:56:35 +0700
commitd25bf74f1abab18bde66d725297f366d58da94cf (patch)
tree540c351565177ea0355623d6ff03689f5f30659f /multimedia
parent969130b17d7d94283d6ad288d04ea5c8c7016828 (diff)
multimedia/beets: Updated for version 2.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/beets/beets.SlackBuild30
-rw-r--r--multimedia/beets/beets.info8
2 files changed, 11 insertions, 27 deletions
diff --git a/multimedia/beets/beets.SlackBuild b/multimedia/beets/beets.SlackBuild
index 21d2b1b97e43..0d691d6b4ea1 100644
--- a/multimedia/beets/beets.SlackBuild
+++ b/multimedia/beets/beets.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for beets
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -29,8 +29,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=beets
-VERSION=${VERSION:-1.6.0}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,20 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -79,11 +62,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
mkdir -p $PKG/usr/share/bash-completion/completions
install -m644 $CWD/beet $PKG/usr/share/bash-completion/completions/
diff --git a/multimedia/beets/beets.info b/multimedia/beets/beets.info
index 2c17f299f23e..f567581d0870 100644
--- a/multimedia/beets/beets.info
+++ b/multimedia/beets/beets.info
@@ -1,10 +1,10 @@
PRGNAM="beets"
-VERSION="1.6.0"
+VERSION="2.0.0"
HOMEPAGE="http://beets.radbox.org"
-DOWNLOAD="https://github.com/beetbox/beets/releases/download/v1.6.0/beets-1.6.0.tar.gz"
-MD5SUM="d03cd61d7083bc62f4b17ce2808df0d8"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/b/beets/beets-2.0.0.tar.gz"
+MD5SUM="925defa8cc8905f008a232f89a329d16"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="munkres Unidecode musicbrainzngs jellyfish python3-confuse python3-mediafile"
+REQUIRES="Sphinx munkres Unidecode musicbrainzngs jellyfish python3-confuse python3-mediafile"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"