aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2024-01-08 22:26:48 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-13 07:14:18 +0700
commit1d9f9eaf051c4941d9be14b7e08b62182e6e5658 (patch)
treed0399a905d5333ca61fc8c2a6397c99c86a18bce /multimedia
parentd3016f2de4ce3e5393ea80ba4ad0d7afb2d50bea (diff)
multimedia/OpenLP: Removed (Unmaintained).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/OpenLP/OpenLP.SlackBuild105
-rw-r--r--multimedia/OpenLP/OpenLP.desktop10
-rw-r--r--multimedia/OpenLP/OpenLP.info10
-rw-r--r--multimedia/OpenLP/README19
-rw-r--r--multimedia/OpenLP/doinst.sh3
-rw-r--r--multimedia/OpenLP/slack-desc19
6 files changed, 0 insertions, 166 deletions
diff --git a/multimedia/OpenLP/OpenLP.SlackBuild b/multimedia/OpenLP/OpenLP.SlackBuild
deleted file mode 100644
index 735b8d3d4fa77..0000000000000
--- a/multimedia/OpenLP/OpenLP.SlackBuild
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for OpenLP
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=OpenLP
-VERSION=${VERSION:-2.0.5}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-install -D -m644 documentation/openlp.1 $PKG/usr/man/man1/openlp.1
-find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
-
-mkdir -p $PKG/usr/share/applications
-install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-
-mkdir -p $PKG/usr/share/pixmaps/
-install -D -m644 resources/images/${PRGNAM,,}-logo-48x48.png $PKG/usr/share/pixmaps/$PRGNAM.png
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt LICENSE copyright.txt documentation/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/multimedia/OpenLP/OpenLP.desktop b/multimedia/OpenLP/OpenLP.desktop
deleted file mode 100644
index 395cb013b13a8..0000000000000
--- a/multimedia/OpenLP/OpenLP.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Name= OpenLP
-Name[he]= OpenLP
-Comment=Open Source Worship Presentation
-Exec=openlp.pyw
-Icon=OpenLP
-Terminal=false
-Type=Application
-Categories=AudioVideo;
-GenericName=Church lyrics projection
diff --git a/multimedia/OpenLP/OpenLP.info b/multimedia/OpenLP/OpenLP.info
deleted file mode 100644
index d5bcc44840fd8..0000000000000
--- a/multimedia/OpenLP/OpenLP.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="OpenLP"
-VERSION="2.0.5"
-HOMEPAGE="https://openlp.org/"
-DOWNLOAD="https://downloads.sourceforge.net/project/openlp/openlp/2.0.5/OpenLP-2.0.5.tar.gz"
-MD5SUM="539626eb8da337814d64e82329e22e78"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="lxml pyenchant SQLAlchemy"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/multimedia/OpenLP/README b/multimedia/OpenLP/README
deleted file mode 100644
index f859aea4f4667..0000000000000
--- a/multimedia/OpenLP/README
+++ /dev/null
@@ -1,19 +0,0 @@
-OpenLP stands for "Open Lyrics Projection" and is presentation
-software developed for churches to provide a single easy to use
-interface for the projection needs of a typical worship service.
-
-First created in 2004, it has steadily grown in features and maturity
-such that it is now a mainstay in hundreds of churches around the
-world.
-
-OpenLP has searchable databases of songs and Bible verses allowing
-them to be projected instantly or saved in a pre-prepared order
-of service file. Themes allow for a variety of presentation
-options and allow you to add attractive visuals to enhance your
-presentations. PowerPoint and OpenOffice presentations, videos and
-audio files can be run from within the program removing the need to
-switch between different programs. Alert messages can be displayed so
-the nursery or car park stewards can notify the congregation easily.
-Remote capability allows the worship leader to change songs, or for
-alert messages to be sent from anywhere on the network, even via smart
-phone/tablet.
diff --git a/multimedia/OpenLP/doinst.sh b/multimedia/OpenLP/doinst.sh
deleted file mode 100644
index 5fb28930db0b9..0000000000000
--- a/multimedia/OpenLP/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/multimedia/OpenLP/slack-desc b/multimedia/OpenLP/slack-desc
deleted file mode 100644
index 8b988ee5e6285..0000000000000
--- a/multimedia/OpenLP/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-OpenLP: OpenLP (Open Source Worship Presentation)
-OpenLP:
-OpenLP: OpenLP stands for "Open Lyrics Projection" and is presentation
-OpenLP: software developed or churches to provide a single easy to use
-OpenLP: nterface for the projection needs of a typical worship service.
-OpenLP: First created in 2004, it has steadily grown in features and maturity
-OpenLP: that it is now a mainstay in hundreds of churches around the world.
-OpenLP:
-OpenLP: Homepage: https://openlp.org/
-OpenLP:
-OpenLP: