aboutsummaryrefslogtreecommitdiff
path: root/multimedia/subtitleripper/subtitleripper.SlackBuild
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2010-05-21 13:12:12 -0500
committerRobby Workman <rworkman@slackbuilds.org>2010-05-23 23:21:40 -0500
commit03545f42a39e148b835061ac9b408d5a50797674 (patch)
treeec756e8a1bc45bdc89ecb8517d50a4a1651f1047 /multimedia/subtitleripper/subtitleripper.SlackBuild
parent3f9c935254d72fafc655232919aa1e41eac81a9a (diff)
downloadslackbuilds-03545f42a39e148b835061ac9b408d5a50797674.tar.xz
multimeda/subtitleripper: Removed (build failure)
cmake issues, it seems...
Diffstat (limited to 'multimedia/subtitleripper/subtitleripper.SlackBuild')
-rw-r--r--multimedia/subtitleripper/subtitleripper.SlackBuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/multimedia/subtitleripper/subtitleripper.SlackBuild b/multimedia/subtitleripper/subtitleripper.SlackBuild
deleted file mode 100644
index a66f74d15586..000000000000
--- a/multimedia/subtitleripper/subtitleripper.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for subtitleripper
-
-# Written by Andre Barboza <bmg.andre@gmail.com>
-
-# Copyright 2009 Andre Barboza
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=subtitleripper
-SRCVER=${SRCVER:-0.3-4}
-VERSION=`echo $SRCVER|sed 's/-/_/'`
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$SRCVER.tgz
-cd $PRGNAM
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-cat $CWD/CMakeLists.txt > CMakeLists.txt
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-cmake . \
- -DCMAKE_INSTALL_PREFIX=/usr \
-
-# Compile the application and install it into the $PKG directory
-make
-make install DESTDIR=$PKG
-
-# Strip binaries and libraries - this can be done with 'make install-strip'
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Copy program documentation into the package
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog README README.gocr README.srttool README.subtitle2pgm README.vobsub \
- $PKG/usr/doc/$PRGNAM-$VERSION
-chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}