aboutsummaryrefslogtreecommitdiff
path: root/multimedia/opencaster/patches
diff options
context:
space:
mode:
authorMario Preksavec <mario at slackware dot hr>2017-11-24 01:01:47 +0000
committerDavid Spencer <idlemoor@slackbuilds.org>2017-11-24 01:01:47 +0000
commit9efc00a7946a049502500e16cdeeb279b115fd6a (patch)
tree37a1cb1157ab02837cf36eb21d32bac0ab516cdb /multimedia/opencaster/patches
parent3df30f21d4a37c14f7373e3ae8652472e1930756 (diff)
multimedia/opencaster: Added (MPEG-TS stream tool).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'multimedia/opencaster/patches')
-rw-r--r--multimedia/opencaster/patches/interface.patch14
-rw-r--r--multimedia/opencaster/patches/path.patch51
-rw-r--r--multimedia/opencaster/patches/tscrypt.patch16
3 files changed, 81 insertions, 0 deletions
diff --git a/multimedia/opencaster/patches/interface.patch b/multimedia/opencaster/patches/interface.patch
new file mode 100644
index 0000000000000..b8dbb879bf742
--- /dev/null
+++ b/multimedia/opencaster/patches/interface.patch
@@ -0,0 +1,14 @@
+Author: Thorsten Alteholz <debian@alteholz.de>
+Index: opencaster-3.2.2/tools/mpe2sec/mpe.c
+===================================================================
+--- opencaster-3.2.2.orig/tools/mpe2sec/mpe.c 2013-11-06 15:13:24.000000000 +0100
++++ opencaster-3.2.2/tools/mpe2sec/mpe.c 2013-11-06 15:13:48.000000000 +0100
+@@ -12,8 +12,6 @@
+ #include <sys/socket.h>
+ #include <net/if.h>
+
+-#include <net/if_tun.h>
+-
+ #include "sectioncrc.h"
+
+ /* pre 2.4.6 compatibility */
diff --git a/multimedia/opencaster/patches/path.patch b/multimedia/opencaster/patches/path.patch
new file mode 100644
index 0000000000000..c2ada77f71df8
--- /dev/null
+++ b/multimedia/opencaster/patches/path.patch
@@ -0,0 +1,51 @@
+Author: Thorsten Alteholz <debian@alteholz.de>
+Description: choose correct path for Debian installation
+Index: opencaster/tools/oc2sec/oc-update.sh
+===================================================================
+--- opencaster.orig/tools/oc2sec/oc-update.sh 2013-08-20 12:31:50.000000000 +0200
++++ opencaster/tools/oc2sec/oc-update.sh 2013-08-23 14:34:13.000000000 +0200
+@@ -74,7 +74,7 @@
+ TEMP_DIR_SEC=`/bin/mktemp -d`
+
+ #Generate the modules from the directory, the modules are stored into a tmp directory TEMP_DIR_MOD
+-/usr/local/bin/file2mod.py $OCDIR $TEMP_DIR_MOD $CAROUSEL_ID $CAROUSEL_ID $ASSOCIATION_TAG $MODULE_VERSION $BLOCK_SIZE $UPDATE_FLAG $COMPRESS_MODE
++/usr/bin/file2mod.py $OCDIR $TEMP_DIR_MOD $CAROUSEL_ID $CAROUSEL_ID $ASSOCIATION_TAG $MODULE_VERSION $BLOCK_SIZE $UPDATE_FLAG $COMPRESS_MODE
+
+ #Compress all modules
+ if [ "$COMPRESS_MODE" = "1" ]
+@@ -82,7 +82,7 @@
+ for file in $TEMP_DIR_MOD/*.mod
+ do
+ /usr/bin/du --apparent-size --block-size 1 $file > $file.size
+- /usr/local/bin/zpipe < $file > $file.z
++ /usr/bin/zpipe < $file > $file.z
+ /bin/mv $file.z $file
+ done
+ fi
+@@ -95,7 +95,7 @@
+ if [ ! -f $file.solo ]
+ then
+ /usr/bin/du --apparent-size --block-size 1 $file > $file.size
+- /usr/local/bin/zpipe < $file > $file.z
++ /usr/bin/zpipe < $file > $file.z
+ /bin/mv $file.z $file
+ else
+ /bin/rm $file.solo
+@@ -104,7 +104,7 @@
+ fi
+
+ #Generate sections from modules, the sections are stored into a tmp directory TEMP_DIR_SEC
+-/usr/local/bin/mod2sec.py $TEMP_DIR_MOD $TEMP_DIR_SEC
++/usr/bin/mod2sec.py $TEMP_DIR_MOD $TEMP_DIR_SEC
+
+ # Check if it is necessary to pad every sections or not, unluckly we have found some decoders having buggy section filtering that needed this
+ if [ "$PAD_ON" = "1" ]
+@@ -134,7 +134,7 @@
+ /bin/cat $TEMP_DIR_SEC/0001_000000.sec >> $TEMP_DIR_SEC/temp_sec # SGW is 1 section of module id 1
+ fi
+ done
+- /usr/local/bin/sec2ts $PID < $TEMP_DIR_SEC/temp_sec > $OCDIR.ts
++ /usr/bin/sec2ts $PID < $TEMP_DIR_SEC/temp_sec > $OCDIR.ts
+ fi
+
+ # Delete temp files
diff --git a/multimedia/opencaster/patches/tscrypt.patch b/multimedia/opencaster/patches/tscrypt.patch
new file mode 100644
index 0000000000000..f3c101660ef92
--- /dev/null
+++ b/multimedia/opencaster/patches/tscrypt.patch
@@ -0,0 +1,16 @@
+Author: Thorsten Alteholz <debian@alteholz.de>
+Description: add tscrypt tool
+Index: opencaster-3.2.1/tools/Makefile
+===================================================================
+--- opencaster-3.2.1.orig/tools/Makefile 2013-09-23 19:18:44.000000000 +0200
++++ opencaster-3.2.1/tools/Makefile 2013-09-23 19:19:08.000000000 +0200
+@@ -10,7 +10,8 @@
+ tsoutputswitch tsccc txt2pes ts2sec \
+ pesdata2ts tsmask tsorts tsororts tspcrrestamp \
+ eitsecfilter eitsecmapper m2ts2cbrts \
+- ts2m2ts tsdiscont eitsecactualtoanother
++ ts2m2ts tsdiscont eitsecactualtoanother \
++ tscrypt
+
+ subdirs: $(SUBDIRS)
+ $(SUBDIRS):