aboutsummaryrefslogtreecommitdiff
path: root/misc/gourmet/gourmet.SlackBuild
diff options
context:
space:
mode:
authorLenard Spencer <lenard@lenardspencer.com>2017-06-19 06:52:22 +0200
committerRobby Workman <rworkman@slackbuilds.org>2021-04-17 23:27:26 -0500
commit2012566954daf6273ece3130bdf17b8eee8aaf55 (patch)
tree07e19bd24196bbd5ba5c8053a5e9d4b91c855851 /misc/gourmet/gourmet.SlackBuild
parent354bc6c32bef6a1189755e3ebe784742bafbabfb (diff)
misc/gourmet: Switch from tostring to tobytes in the code.
This is needed for the newer python-2.7.x. Include two additional dependencies Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'misc/gourmet/gourmet.SlackBuild')
-rw-r--r--misc/gourmet/gourmet.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/misc/gourmet/gourmet.SlackBuild b/misc/gourmet/gourmet.SlackBuild
index e9a2f0f93dd7c..0121943095d5b 100644
--- a/misc/gourmet/gourmet.SlackBuild
+++ b/misc/gourmet/gourmet.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=gourmet
VERSION=${VERSION:-0.17.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch to replace removed tostring() with tobytes()
+patch -p1 < $CWD/tostring-to-tobytes.patch
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \