aboutsummaryrefslogtreecommitdiff
path: root/misc/asr-manpages/asr-manpages.SlackBuild
diff options
context:
space:
mode:
authorMichiel van Wessem <michiel@slackbuilds.org>2010-05-11 22:54:28 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-11 22:54:28 +0200
commita630d7216dbec08a4e30b1a981594428b4a90048 (patch)
tree4e1f8bbc8604b2cba8f28a9a02aba44fbdd90cb0 /misc/asr-manpages/asr-manpages.SlackBuild
parent04c4c5e45b12ce0adb5a278472004a0cecac73ea (diff)
downloadslackbuilds-a630d7216dbec08a4e30b1a981594428b4a90048.tar.xz
misc/asr-manpages: Added to 12.1 repository
Diffstat (limited to 'misc/asr-manpages/asr-manpages.SlackBuild')
-rw-r--r--misc/asr-manpages/asr-manpages.SlackBuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/misc/asr-manpages/asr-manpages.SlackBuild b/misc/asr-manpages/asr-manpages.SlackBuild
new file mode 100644
index 000000000000..e9ec0873fba0
--- /dev/null
+++ b/misc/asr-manpages/asr-manpages.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Slackware build script for asr-manpages
+
+# Copyright 2007-2008 Michiel van Wessem, Manchester, United Kingdom
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=asr-manpages
+VERSION=1.3.6
+SRC_VERSION=1.3
+DEB_VERSION=1.3-6
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRC_VERSION
+tar xvf $CWD/${PRGNAM}_$SRC_VERSION.orig.tar.gz
+cd $PRGNAM-$SRC_VERSION.orig
+
+# Patch the manpages to the latest version.
+patch -p1 < $CWD/${PRGNAM}_$DEB_VERSION.diff
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Create the directories we need
+mkdir -p $PKG/usr/man/man{1,2,3,5,7,8}
+install -m 0644 $CWD/google.7 $PKG/usr/man/man7/google.7fun
+for manpage in $(echo *fun); do
+ section=$(echo $manpage | awk -F. '{print $2}' | colrm 2 4)
+ install -m 0644 $manpage $PKG/usr/man/man$section/$manpage
+done
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog debian/copyright $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz