aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorSteven Voges <svoges.sbo@gmail.com>2023-09-14 21:24:49 +0900
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-17 00:10:16 +0700
commita2c3fdc1cd3df4116d957529390da7a4305c42ab (patch)
tree31436981a1d133493508bc69002b894aac5749f4 /libraries
parent03845d744eabc1b031ee072c063f4547729a748b (diff)
libraries/html5lib: Updated for version 1.1, new maint.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/html5lib/README15
-rw-r--r--libraries/html5lib/html5lib.SlackBuild17
-rw-r--r--libraries/html5lib/html5lib.info12
-rw-r--r--libraries/html5lib/slack-desc14
4 files changed, 26 insertions, 32 deletions
diff --git a/libraries/html5lib/README b/libraries/html5lib/README
index a38654faac06..37294a67bc05 100644
--- a/libraries/html5lib/README
+++ b/libraries/html5lib/README
@@ -1,12 +1,5 @@
-html5lib (HTML parser based on the HTML5 specification)
+html5lib is a pure-python library for parsing HTML. It is designed to
+conform to the WHATWG HTML specification, as is implemented by all
+major web browsers.
-HTML parser designed to follow the HTML5 specification. The parser is
-designed to handle all flavours of HTML and parses invalid documents
-using well-defined error handling rules compatible with the behaviour of
-major desktop web browsers.
-
-Output is to a tree structure; the current release supports output
-to DOM, ElementTree and lxml tree formats as well as a simple
-custom format.
-
-Optional: datrie, lxml, and genshi
+Optional dependencies: chardet, genshi, and lxml
diff --git a/libraries/html5lib/html5lib.SlackBuild b/libraries/html5lib/html5lib.SlackBuild
index 7b1fcac74bc6..fa754e8b2558 100644
--- a/libraries/html5lib/html5lib.SlackBuild
+++ b/libraries/html5lib/html5lib.SlackBuild
@@ -1,8 +1,10 @@
#!/bin/bash
# Slackware build script for html5lib
-# Written by Šime Ramov <s@ramov.com>
+
+# Copyright 2023 Steven Voges <Oregon, USA>
# Copyright 2017-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Written by Šime Ramov <s@ramov.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=html5lib
-VERSION=${VERSION:-1.0.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -65,14 +64,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ *.rst LICENSE PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/html5lib/html5lib.info b/libraries/html5lib/html5lib.info
index 87f492c60212..2640ea6836e9 100644
--- a/libraries/html5lib/html5lib.info
+++ b/libraries/html5lib/html5lib.info
@@ -1,10 +1,10 @@
PRGNAM="html5lib"
-VERSION="1.0.1"
-HOMEPAGE="https://github.com/html5lib/"
-DOWNLOAD="https://pypi.io/packages/source/h/html5lib/html5lib-1.0.1.tar.gz"
-MD5SUM="942a0688d6bdf20d087c9805c40182ad"
+VERSION="1.1"
+HOMEPAGE="https://github.com/html5lib/html5lib-python"
+DOWNLOAD="https://files.pythonhosted.org/packages/ac/b6/b55c3f49042f1df3dcd422b7f224f939892ee94f22abcf503a9b7339eaf2/html5lib-1.1.tar.gz"
+MD5SUM="6748742e2ec4cb99287a6bc82bcfe2b0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-webencodings"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/libraries/html5lib/slack-desc b/libraries/html5lib/slack-desc
index 4690761b92fe..e4a55d3a1d77 100644
--- a/libraries/html5lib/slack-desc
+++ b/libraries/html5lib/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
html5lib: html5lib (HTML parser based on the HTML5 specification)
html5lib:
-html5lib: HTML parser designed to follow the HTML5 specification. The parser
-html5lib: is designed to handle all flavours of HTML and parses invalid
-html5lib: documents using well-defined error handling rules compatible with
-html5lib: the behaviour of major desktop web browsers.
+html5lib: Standards-compliant library for parsing and serializing HTML documents
+html5lib: and fragments in Python
+html5lib:
+html5lib: Homepage: https://github.com/html5lib/html5lib-python
+html5lib:
+html5lib:
+html5lib:
html5lib:
-html5lib: Output is to a tree structure; the current release supports output
-html5lib: to DOM, ElementTree and lxml tree formats as well as a simple
-html5lib: custom format.
html5lib: