aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorWilliam PC <w_calandrini[at]hotmail[dot]com>2022-12-09 00:15:51 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-10 07:43:13 +0700
commitd17695aaf683123c82ce4516255a7007329587ce (patch)
treed6e032479a1ae12dab992f2a4fc44b9040a880c1 /libraries
parentaaa409fc219e22870ac20b609c4da279841d909d (diff)
libraries/gismo: Added (C++ library for isogeometric analysis)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/gismo/README23
-rw-r--r--libraries/gismo/gismo.SlackBuild147
-rw-r--r--libraries/gismo/gismo.info10
-rw-r--r--libraries/gismo/slack-desc19
4 files changed, 199 insertions, 0 deletions
diff --git a/libraries/gismo/README b/libraries/gismo/README
new file mode 100644
index 000000000000..b8292a0d099d
--- /dev/null
+++ b/libraries/gismo/README
@@ -0,0 +1,23 @@
+ G+Smo (pronounced gismo or gizmo) is a C++ library for isogeometric
+analysis (IGA). Geometry plus simulation modules aims at the seamless
+integration of Computer-aided Design (CAD) and Finite Element
+Analysis (FEA).
+
+ G+Smo (Geometry + Simulation Modules, pronounced "gismo") is an
+open-source C++ library that brings together mathematical tools for
+geometric design and numerical simulation. It implements the
+relatively new paradigm of isogeometric analysis, which suggests the
+use of a unified framework in the design and analysis pipeline. G+Smo
+is an object-oriented, cross-platform, template C++ library and
+follows the generic programming principle, with a focus on both
+efficiency and ease of use. The library aims at providing access to
+high quality, open-source software to the forming isogeometric
+numerical simulation community and beyond.
+
+
+Optional building modes set with environment variables:
+ - QTAPP=yes : build the QT application
+ - OMP=yes : building with OpenMP
+ - MPI=yes : build with MPI support (requires mpich or openmpi)
+ - HYBRID=yes : OpenMP+MPI (requires mpich or openmpi)
+ - VTK=yes : use VTK, requires VTK package.
diff --git a/libraries/gismo/gismo.SlackBuild b/libraries/gismo/gismo.SlackBuild
new file mode 100644
index 000000000000..75cb4f8b710c
--- /dev/null
+++ b/libraries/gismo/gismo.SlackBuild
@@ -0,0 +1,147 @@
+#!/bin/bash
+
+# Slackware build script for gismo
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=gismo
+VERSION=${VERSION:-21.12.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ "${QTAPP:-no}" == "yes" ]; then
+ OPT_BUILD="-DGISMO_BUILD_QT_APP=ON"
+fi
+
+if [ "${OMP:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD -DGISMO_WITH_OPENMP=ON"
+fi
+
+if [ "${MPI:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD -DGISMO_WITH_MPI=ON"
+fi
+
+if [ "${HYBRID:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD -DGISMO_WITH_OPENMP=ON -DGISMO_WITH_MPI=ON"
+fi
+
+if [ "${VTK:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD -DGISMO_WITH_VTK:BOOL=ON"
+fi
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
+ -DBIN_INSTALL_DIR=libexec/$PRGNAM \
+ -DGISMO_BUILD_LIB:BOOL=ON \
+ -DGISMO_BUILD_EXAMPLES:BOOL=OFF \
+ $OPT_BUILD \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+# install examples
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -a examples $PKG/usr/share/$PRGNAM-$VERSION
+
+# fix cmakefile for examples
+sed -i '18,21s/^#//' $PKG/usr/share/$PRGNAM-$VERSION/examples/CMakeLists.txt
+
+# fix cmake to find library
+sed -i '33s/_static//' $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM/gismoUse.cmake
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYRIGHT.txt LICENSE.txt doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/gismo/gismo.info b/libraries/gismo/gismo.info
new file mode 100644
index 000000000000..4f0c88adf3e0
--- /dev/null
+++ b/libraries/gismo/gismo.info
@@ -0,0 +1,10 @@
+PRGNAM="gismo"
+VERSION="21.12.0"
+HOMEPAGE="https://gismo.github.io"
+DOWNLOAD="https://github.com/gismo/gismo/archive/v21.12.0/gismo-21.12.0.tar.gz"
+MD5SUM="0d02efd5d9b13726c1d6db6b48499519"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/libraries/gismo/slack-desc b/libraries/gismo/slack-desc
new file mode 100644
index 000000000000..469af2227631
--- /dev/null
+++ b/libraries/gismo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gismo: gismo (C++ library for isogeometric analysis)
+gismo:
+gismo:
+gismo:
+gismo: G+Smo (pronounced gismo or gizmo) is a C++ library for isogeometric
+gismo: analysis (IGA). Geometry plus simulation modules aims at the seamless
+gismo: integration of Computer-aided Design (CAD) and Finite Element
+gismo: Analysis (FEA).
+gismo:
+gismo:
+gismo: