aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-25 20:52:03 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-25 20:52:03 +0700
commit91a67eccf70b26a6c547c39efd2c64eab5f7c468 (patch)
tree078d7cc6c986f46988594ca722828805312e9b19 /libraries
parent0a50f65afb6a9dadaa1d6d47b9872c2efc573d0e (diff)
downloadslackbuilds-91a67eccf70b26a6c547c39efd2c64eab5f7c468.tar.xz
libraries/pymdstat: Removed (use python3-pymdstat).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pymdstat/README2
-rw-r--r--libraries/pymdstat/pymdstat.SlackBuild88
-rw-r--r--libraries/pymdstat/pymdstat.info10
-rw-r--r--libraries/pymdstat/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/libraries/pymdstat/README b/libraries/pymdstat/README
deleted file mode 100644
index a24236be7d05..000000000000
--- a/libraries/pymdstat/README
+++ /dev/null
@@ -1,2 +0,0 @@
-PyMDstat is a pythonic library to parse /proc/mdstat, which shows a
-snapshot of the kernel's RAID/md state.
diff --git a/libraries/pymdstat/pymdstat.SlackBuild b/libraries/pymdstat/pymdstat.SlackBuild
deleted file mode 100644
index 55c78a32a177..000000000000
--- a/libraries/pymdstat/pymdstat.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pymdstat
-
-# Copyright 2015-2017 Philip Lacroix <slackph at posteo dot de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pymdstat
-VERSION=${VERSION:-0.4.2}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
-
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
- -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-PRGUSR=$PKG/usr
-PRGSHR=$PKG/usr/share
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
-# Install documentation.
-mkdir -p $PRGDOC
-mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
-rm -rf $PRGSHR
-cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/pymdstat/pymdstat.info b/libraries/pymdstat/pymdstat.info
deleted file mode 100644
index d2127c1333b5..000000000000
--- a/libraries/pymdstat/pymdstat.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pymdstat"
-VERSION="0.4.2"
-HOMEPAGE="https://github.com/nicolargo/pymdstat"
-DOWNLOAD="https://github.com/nicolargo/pymdstat/archive/v0.4.2/pymdstat-0.4.2.tar.gz"
-MD5SUM="49cf57575fd15cb8ee6655d5c353ce09"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Philip Lacroix"
-EMAIL="slackph at posteo dot de"
diff --git a/libraries/pymdstat/slack-desc b/libraries/pymdstat/slack-desc
deleted file mode 100644
index f4652856f948..000000000000
--- a/libraries/pymdstat/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pymdstat: pymdstat (library to parse /proc/mdstat)
-pymdstat:
-pymdstat: PyMDstat is a pythonic library to parse /proc/mdstat, which shows a
-pymdstat: snapshot of the kernel's RAID/md state.
-pymdstat:
-pymdstat: Homepage: https://github.com/nicolargo/pymdstat
-pymdstat:
-pymdstat:
-pymdstat:
-pymdstat:
-pymdstat: