aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2021-04-22 20:20:11 -0500
committerRobby Workman <rworkman@slackbuilds.org>2021-04-22 20:20:11 -0500
commit5306e5aa8c64bbcc2b44dca2cbb79a164e2ac3b8 (patch)
tree844c8e4795a2618dd516c356423c29682be5e5c8 /libraries
parentb5d6078a266419ab861661ee855473b79e508123 (diff)
downloadslackbuilds-5306e5aa8c64bbcc2b44dca2cbb79a164e2ac3b8.tar.xz
libraries/pyechonest: Removed (dead upstream)
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pyechonest/README18
-rw-r--r--libraries/pyechonest/pyechonest.SlackBuild87
-rw-r--r--libraries/pyechonest/pyechonest.info10
-rw-r--r--libraries/pyechonest/slack-desc19
4 files changed, 0 insertions, 134 deletions
diff --git a/libraries/pyechonest/README b/libraries/pyechonest/README
deleted file mode 100644
index 52976aa5b92a..000000000000
--- a/libraries/pyechonest/README
+++ /dev/null
@@ -1,18 +0,0 @@
-Tap into The Echo Nest's Musical Brain for the best music search,
-information, recommendations and remix tools on the web.
-
-Pyechonest is an open source Python library for the Echo Nest API.
-With Pyechonest you have Python access to the entire set of API
-methods including:
-
-- artist - search for artists by name, description, or attribute,
- and get back detailed information about any artist including audio,
- similar artists, blogs, familiarity, hotttnesss, news, reviews,
- urls and video.
-- song - search songs by artist, title, description, or attribute
- (tempo, duration, etc) and get detailed information back about each
- song, such as hotttnesss, audio_summary, or tracks.
-- track - upload a track to the Echo Nest and receive summary
- information about the track including key, duration, mode, tempo,
- time signature along with detailed track info including timbre,
- pitch, rhythm and loudness information.
diff --git a/libraries/pyechonest/pyechonest.SlackBuild b/libraries/pyechonest/pyechonest.SlackBuild
deleted file mode 100644
index e3b8697b512a..000000000000
--- a/libraries/pyechonest/pyechonest.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyechonest
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pyechonest
-VERSION=${VERSION:-9.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-PYTHON=python
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-$PYTHON setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyechonest/pyechonest.info b/libraries/pyechonest/pyechonest.info
deleted file mode 100644
index ff2b21a2e0c6..000000000000
--- a/libraries/pyechonest/pyechonest.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyechonest"
-VERSION="9.0.0"
-HOMEPAGE="https://github.com/echonest/pyechonest"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyechonest/pyechonest-9.0.0.tar.gz"
-MD5SUM="c633dce658412e3ec553efd25d7d2686"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/pyechonest/slack-desc b/libraries/pyechonest/slack-desc
deleted file mode 100644
index 244e52f95282..000000000000
--- a/libraries/pyechonest/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyechonest: pyechonest (Python interface to The Echo Nest APIs)
-pyechonest:
-pyechonest: Tap into The Echo Nest's Musical Brain for the best music search,
-pyechonest: information, recommendations and remix tools on the web.
-pyechonest: Pyechonest is an open source Python library for the Echo Nest API.
-pyechonest: With Pyechonest you have Python access to the entire set of API
-pyechonest: methods.
-pyechonest:
-pyechonest: homepage: https://github.com/echonest/pyechonest
-pyechonest:
-pyechonest: