aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2024-10-06 04:57:24 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-12 11:34:41 +0700
commit93bc54b15ac4f23018787a11c77297ff17a60b65 (patch)
tree9788487a7292b51b1f88de9a09ddd68fd9ca2e91 /libraries
parent777cf919ff4ee4a61ea2c79d084dc4a7f395913e (diff)
libraries/configobj: Removed (use python[23]-configobj).
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/configobj/README4
-rw-r--r--libraries/configobj/configobj.SlackBuild72
-rw-r--r--libraries/configobj/configobj.info10
-rw-r--r--libraries/configobj/slack-desc19
4 files changed, 0 insertions, 105 deletions
diff --git a/libraries/configobj/README b/libraries/configobj/README
deleted file mode 100644
index e253bee94fa4..000000000000
--- a/libraries/configobj/README
+++ /dev/null
@@ -1,4 +0,0 @@
-configobj (configuration file python module)
-
-A python module for ultra simple handling of configuration files.
-Also useful for human readable data persistence. Flexible and simple.
diff --git a/libraries/configobj/configobj.SlackBuild b/libraries/configobj/configobj.SlackBuild
deleted file mode 100644
index cbe977f848e6..000000000000
--- a/libraries/configobj/configobj.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for configobj
-
-# Written by Luis Henrique <email removed>
-
-# Modified by B. Watson <urchlay@slackware.uk>
-
-# 20230520 bkw: python => python2 (no other changes).
-# 20230510 bkw: update for v5.0.8
-# 20200811 bkw: add missing "six" dep, pointed out by jc_anatole
-# 20200117 bkw: update for v5.0.6
-# 20140915 bkw:
-# - Took over maintenance
-# - Exclude __MACOSX dir from unzip command
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=configobj
-VERSION=${VERSION:-5.0.8}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-# ARCH doesn't really matter except x86_64 will get stuff
-# installed to lib64. We don't need LIBDIRSUFFIX because setup.py
-# already knows to do this.
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-python2 setup.py install --root=$PKG
-
-which python3 &> /dev/null && python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-[ -d docs ] && cp -a docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/configobj/configobj.info b/libraries/configobj/configobj.info
deleted file mode 100644
index a965ff8f4703..000000000000
--- a/libraries/configobj/configobj.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="configobj"
-VERSION="5.0.8"
-HOMEPAGE="https://pypi.org/project/configobj/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/c/configobj/configobj-5.0.8.tar.gz"
-MD5SUM="8dda7b31bb3aea87ecfe3b7a87812b17"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="urchlay@slackware.uk"
diff --git a/libraries/configobj/slack-desc b/libraries/configobj/slack-desc
deleted file mode 100644
index 7052bf3c5c1c..000000000000
--- a/libraries/configobj/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-configobj: configobj (configuration file python module)
-configobj:
-configobj: A python module for ultra simple handling of configuration files.
-configobj: Also useful for human readable data persistence. Flexible and simple.
-configobj:
-configobj: Homepage: http://www.voidspace.org.uk/python/modules.shtml#configobj
-configobj:
-configobj:
-configobj:
-configobj:
-configobj: