aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorEdward W. Koenig <kingbeowulf@linuxgalaxy.org>2024-08-11 20:17:47 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-17 18:14:37 +0700
commitd5de8a0ae8fc5b4fad07ad25b88b229c7f5dde82 (patch)
treec7bdc817cf58bfb1e3653cc50ad40774f05cea80 /libraries
parent14c0ac74bb322f5f9d44bf59f8ae328838b0cb51 (diff)
libraries/poco: Updated for version 1.13.3
Signed-off-by: Edward W. Koenig <kingbeowulf@linuxgalaxy.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/poco/README9
-rw-r--r--libraries/poco/poco.SlackBuild43
-rw-r--r--libraries/poco/poco.info6
-rw-r--r--libraries/poco/poco_x64.patch22
4 files changed, 29 insertions, 51 deletions
diff --git a/libraries/poco/README b/libraries/poco/README
index 353a2b4c5011e..43774a399b2e9 100644
--- a/libraries/poco/README
+++ b/libraries/poco/README
@@ -4,9 +4,12 @@ server, mobile and embedded systems.
PostgreSQL (on Sbo) and libiodbc (part of Slackware) or UnixODBC
(on SBo) are optional dependencies that will be automatically picked
-up during configuration. If you have PostgreSQL installed and want to
-compile the corresponding database connector, do this:
+up during configuration.
- POSTGRESQL=yes ./poco.SlackBuild
+By default, the build will use the internal libs for sqlite, zlib,
+pcre2, expat, etc. To use the Slackware versions:
+BUNDLE=no ./poco.SlackBuild
+This will disable any functionality not already included with or
+added to Slackware.
diff --git a/libraries/poco/poco.SlackBuild b/libraries/poco/poco.SlackBuild
index f941dbb2b7d69..fa34c7a8c44a8 100644
--- a/libraries/poco/poco.SlackBuild
+++ b/libraries/poco/poco.SlackBuild
@@ -27,9 +27,9 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=poco
-VERSION=${VERSION:-1.12.5}
+VERSION=${VERSION:-1.13.3}
EDITION=all
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,12 +49,11 @@ if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
exit 0
fi
-# Make optionally detected components really optional as they are in
-# CMAKE build configuration upstream.
-if [ ${POSTGRESQL:-no} = "no" ]; then
- NOPOSTGRESQL="--omit=Data/PostgreSQL"
+# Optionally disable bundles libs in favor of Slackware's versions
+if [ ${BUNDLE:-no} = "no" ]; then
+ NOBUNDLE="-DPOCO_UNBUNDLED=ON"
else
- NOPOSTGRESQL=""
+ NOBUNDLE=""
fi
TMP=${TMP:-/tmp/SBo}
@@ -81,7 +80,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION-$EDITION
-tar xvf $CWD/$PRGNAM-$VERSION-$EDITION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION-$EDITION.tar.bz2
cd $PRGNAM-$VERSION-$EDITION
chown -R root:root .
find -L . \
@@ -90,23 +89,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if [ "$ARCH" = "x86_64" ]; then
- patch -p1 < $CWD/poco_x64.patch
-fi
-
# Slackware ships with MariaDB not MySQL, patch from Arch Linux
patch -p1 < $CWD/poco_mariadb.patch
-./configure \
- --prefix=/usr \
- --no-tests \
- --no-samples \
- $NOPOSTGRESQL \
- --sqlite-thread-safe=2 \
- --shared
-
-make
-make install DESTDIR=$PKG
+mkdir -p cmake-build
+cd cmake-build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ $NOBUNDLE \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -117,7 +114,7 @@ find $PKG -name perllocal.pod \
| xargs rm -f
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG CONTRIBUTORS NEWS LICENSE VERSION README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG CONTRIBUTORS LICENSE MANIFEST VERSION README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -f $PKG/usr/lib*/*.la
diff --git a/libraries/poco/poco.info b/libraries/poco/poco.info
index e2bd2787b73df..d756b55862d9a 100644
--- a/libraries/poco/poco.info
+++ b/libraries/poco/poco.info
@@ -1,8 +1,8 @@
PRGNAM="poco"
-VERSION="1.12.5"
+VERSION="1.13.3"
HOMEPAGE="https://pocoproject.org"
-DOWNLOAD="https://pocoproject.org/releases/poco-1.12.5/poco-1.12.5-all.tar.gz"
-MD5SUM="5bdbf497ff3e65d92a66ecae0a963397"
+DOWNLOAD="https://pocoproject.org/releases/poco-1.13.3/poco-1.13.3-all.tar.bz2"
+MD5SUM="ec5ce614fff2ed1825bb776fa1292d4d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/poco/poco_x64.patch b/libraries/poco/poco_x64.patch
deleted file mode 100644
index 40966da0b27cc..0000000000000
--- a/libraries/poco/poco_x64.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- poco-1.7.3-all/Makefile.original 2016-05-21 10:30:38.468392077 +0100
-+++ poco-1.7.3-all/Makefile 2016-05-21 10:31:06.823679098 +0100
-@@ -95,7 +95,7 @@
-
- install: libexecs
- mkdir -p $(INSTALLDIR)/include/Poco
-- mkdir -p $(INSTALLDIR)/lib
-+ mkdir -p $(INSTALLDIR)/lib64
- mkdir -p $(INSTALLDIR)/bin
- for comp in $(filter-out $(foreach f,$(OMIT),$f%),$(COMPONENTS)) ; do \
- if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
-@@ -109,8 +109,8 @@
- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "cygPoco*" -type f -exec cp -f {} $(INSTALLDIR)/bin \;
- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "cygPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/bin \;
- endif
-- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
-- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
-+ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib64 \;
-+ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib64 \;
-
- libexecs = Foundation-libexec XML-libexec JSON-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec MongoDB-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
- tests = Foundation-tests XML-tests JSON-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests MongoDB-tests Zip-tests