aboutsummaryrefslogtreecommitdiff
path: root/libraries/zfec
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2023-07-09 09:59:01 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-09 22:04:22 +0700
commitd8132a7c4a9b93c317555c1614d98859ce765db3 (patch)
tree145c3fee95d447ac6fde91ba388fe76c473611fd /libraries/zfec
parent9829df8a71f7fc6eef2ef24abe0490ecac9fb625 (diff)
libraries/zfec: Removed, broken, unrequired
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/zfec')
-rw-r--r--libraries/zfec/README25
-rw-r--r--libraries/zfec/slack-desc19
-rw-r--r--libraries/zfec/zfec.SlackBuild100
-rw-r--r--libraries/zfec/zfec.info10
4 files changed, 0 insertions, 154 deletions
diff --git a/libraries/zfec/README b/libraries/zfec/README
deleted file mode 100644
index 0ae6f6963ead..000000000000
--- a/libraries/zfec/README
+++ /dev/null
@@ -1,25 +0,0 @@
-This package implements an "erasure code", or "forward error
-correction code".
-
-You may use this package under the GNU General Public License, version
-2 or, at your option, any later version. You may use this package
-under the Transitive Grace Period Public Licence, version 1.0. (You
-may choose to use this package under the terms of either licence,
-at your option.) See the file COPYING.GPL for the terms of the GNU
-General Public License, version 2. See the file COPYING.TGPPL.html for
-the terms of the Transitive Grace Period Public Licence, version 1.0.
-
-The most widely known example of an erasure code is the RAID-5
-algorithm which makes it so that in the event of the loss of any one
-hard drive, the stored data can be completely recovered. The algorithm
-in the zfec package has a similar effect, but instead of recovering
-from the loss of only a single element, it can be parameterized to
-choose in advance the number of elements whose loss it can tolerate.
-
-This package is largely based on the old "fec" library by Luigi Rizzo
-et al., which is a mature and optimized implementation of erasure
-coding. The zfec package makes several changes from the original "fec"
-package, including addition of the Python API, refactoring of the C
-API to support zero-copy operation, a few clean-ups and optimizations
-of the core code itself, and the addition of a command-line tool named
-"zfec".
diff --git a/libraries/zfec/slack-desc b/libraries/zfec/slack-desc
deleted file mode 100644
index 647137b95966..000000000000
--- a/libraries/zfec/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-zfec: zfec (fast erasure codec)
-zfec:
-zfec: Fast, portable, programmable erasure coding a.k.a. "forward error
-zfec: correction": the generation of redundant blocks of information such
-zfec: that if some blocks are lost then the original data can be recovered
-zfec: from the remaining blocks. The zfec package includes command-line
-zfec: tools, C API, Python API, and Haskell API
-zfec:
-zfec: Homepage: https://pypi.python.org/pypi/zfec
-zfec:
-zfec:
diff --git a/libraries/zfec/zfec.SlackBuild b/libraries/zfec/zfec.SlackBuild
deleted file mode 100644
index 3a652a64357d..000000000000
--- a/libraries/zfec/zfec.SlackBuild
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for zfec.
-
-# Copyright 2012-2022 Markus Reichelt, Aachen, DE
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=zfec
-VERSION=${VERSION:-1.5.7.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING.GPL COPYING.TGPPL.rst README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/zfec/zfec.info b/libraries/zfec/zfec.info
deleted file mode 100644
index ec9f6f252304..000000000000
--- a/libraries/zfec/zfec.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="zfec"
-VERSION="1.5.7.2"
-HOMEPAGE="https://pypi.python.org/pypi/zfec"
-DOWNLOAD="https://files.pythonhosted.org/packages/06/93/1afdfb33e5515845a62d946ca9d53b18477f77cd7608ab7563c4ebbd2dba/zfec-1.5.7.2.tar.gz"
-MD5SUM="19f73a73d24ff221b870ba4a98931b02"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="darcsver pyutil"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"