aboutsummaryrefslogtreecommitdiff
path: root/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
diff options
context:
space:
mode:
authorAlexander Verbovetsky <alik@ejik.org>2022-05-07 07:08:05 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-07 13:59:30 +0700
commita7600dda8fc1904db6e3c0e29b9210cf737ead2b (patch)
tree748ef2dbd2d5660fce5cd8f78d8b0ba1554978bf /libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
parent6249c3d10e31ea4b2af954e481f91c6b3b9239d6 (diff)
libraries/python-ruamel: Updated for version 0.16.13.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild')
-rw-r--r--libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
index ee57fa90b1fdf..206783761effb 100644
--- a/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
+++ b/libraries/python-ruamel.yaml/python-ruamel.yaml.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-ruamel.yaml
-# Copyright 2019-2021, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2019-2022, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-ruamel.yaml
-VERSION=${VERSION:-0.16.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.16.13}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -66,11 +63,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-RUAMEL_NO_PIP_INSTALL_CHECK=1 python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- RUAMEL_NO_PIP_INSTALL_CHECK=1 python3 setup.py install --root=$PKG
-fi
+RUAMEL_NO_PIP_INSTALL_CHECK=1 python2 setup.py install --root=$PKG
+RUAMEL_NO_PIP_INSTALL_CHECK=1 python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true