aboutsummaryrefslogtreecommitdiff
path: root/libraries/pycurl
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/pycurl
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/pycurl')
-rw-r--r--libraries/pycurl/README19
-rw-r--r--libraries/pycurl/pycurl.SlackBuild72
-rw-r--r--libraries/pycurl/pycurl.info10
-rw-r--r--libraries/pycurl/slack-desc19
4 files changed, 0 insertions, 120 deletions
diff --git a/libraries/pycurl/README b/libraries/pycurl/README
deleted file mode 100644
index f8b0bfb2c345a..0000000000000
--- a/libraries/pycurl/README
+++ /dev/null
@@ -1,19 +0,0 @@
-PycURL is a Python interface to libcurl. PycURL can be used to fetch
-objects identified by a URL from a Python program, similar to the urllib
-Python module. PycURL is mature, very fast, and supports a lot of features.
-Overview
-
- * libcurl is a free and easy-to-use client-side URL transfer library,
- supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and
- LDAP. libcurl supports HTTPS certificates, HTTP POST, HTTP PUT,
- FTP uploading, kerberos, HTTP form based upload, proxies, cookies,
- user+password authentication, file transfer resume, http proxy tunneling
- and more!
-
- * libcurl is highly portable, it builds and works identically on
- numerous platforms, including Solaris, NetBSD, FreeBSD, OpenBSD,
- Darwin, HPUX, IRIX, AIX, Tru64, Linux, Windows, Amiga, OS/2, BeOs,
- Mac OS X, Ultrix, QNX, OpenVMS, RISC OS, Novell NetWare, DOS and more...
-
- * libcurl is free, thread-safe, IPv6 compatible, feature rich, well
- supported and fast.
diff --git a/libraries/pycurl/pycurl.SlackBuild b/libraries/pycurl/pycurl.SlackBuild
deleted file mode 100644
index 5a2f5f981dfa5..0000000000000
--- a/libraries/pycurl/pycurl.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pycurl
-
-# Written by Grissiom chaos.proton@gmail.com
-
-PRGNAM=pycurl
-VERSION=${VERSION:-7.19.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e # Exit on most errors
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
-mv ${PKG}/usr/share/doc/${PRGNAM}/* -t ${PKG}/usr/doc/$PRGNAM-$VERSION
-rm -rf ${PKG}/usr/share
-
-cp PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pycurl/pycurl.info b/libraries/pycurl/pycurl.info
deleted file mode 100644
index 2e51c2b32ee3d..0000000000000
--- a/libraries/pycurl/pycurl.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pycurl"
-VERSION="7.19.0"
-HOMEPAGE="http://pycurl.sourceforge.net/"
-DOWNLOAD="http://pycurl.sourceforge.net/download/pycurl-7.19.0.tar.gz"
-MD5SUM="919d58fe37e69fe87ce4534d8b6a1c7b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="grissiom"
-EMAIL="chaos.proton@gmail.com"
-APPROVED="dsomero"
diff --git a/libraries/pycurl/slack-desc b/libraries/pycurl/slack-desc
deleted file mode 100644
index 6d91ef6e87432..0000000000000
--- a/libraries/pycurl/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pycurl: PycURL (Python interface to libcurl).
-pycurl:
-pycurl: libcurl is a free and easy-to-use client-side URL transfer library,
-pycurl: supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and
-pycurl: LDAP. libcurl supports HTTPS certificates, HTTP POST, HTTP PUT,
-pycurl: FTP uploading, kerberos, HTTP form based upload, proxies, cookies,
-pycurl: user+password authentication, file transfer resume, http proxy
-pycurl: tunneling and more!
-pycurl:
-pycurl: Homepage:http://pycurl.sourceforge.net/
-pycurl: