aboutsummaryrefslogtreecommitdiff
path: root/libraries/matplotlib/matplotlib.SlackBuild
diff options
context:
space:
mode:
authorSerban Udrea <S.Udrea@gsi.de>2018-11-02 22:03:28 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:45:01 +0700
commit257c9023f2f89860a2413b9b114b766b7e217215 (patch)
tree04f37937b56137d555ed5695cf019620f202f386 /libraries/matplotlib/matplotlib.SlackBuild
parentef9b4f99c70a8d95cc707a2ee6576b372caf5920 (diff)
libraries/matplotlib: Updated for version 2.2.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/matplotlib/matplotlib.SlackBuild')
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild41
1 files changed, 12 insertions, 29 deletions
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
index 980d4a7256b0..ffb54ac04349 100644
--- a/libraries/matplotlib/matplotlib.SlackBuild
+++ b/libraries/matplotlib/matplotlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for matplotlib
-# Copyright 2011-2016 Serban Udrea <s.udrea@gsi.de>
+# Copyright 2011-2018 Serban Udrea <s.udrea@gsi.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -25,17 +25,16 @@
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
-# Patch for libpng borrowed from Arch Linux
-# Updated up to version 1.5.2 by Serban Udrea <S.Udrea@gsi.de>
+# Patch for libpng borrowed from Arch Linux (no longer needed, 2016.08.28, S.U.)
+# Updated up to version 2.2.3 by Serban Udrea <S.Udrea@gsi.de>
PRGNAM=matplotlib
-VERSION=${VERSION:-1.5.2}
+VERSION=${VERSION:-2.2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-TARBALL_VERSION=${TARBALL_VERSION:-1.5.2} # Tarball sometimes has a wrong version number
-DISABLE_TESTS=${DISABLE_TESTS:-Y}
-DISABLE_TK_TESTS=${DISABLE_TK_TESTS:-Y}
+TARBALL_VERSION=${TARBALL_VERSION:-2.2.3} # Tarball sometimes has a wrong version number
+ENABLE_TESTS=${ENABLE_TESTS:-N}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -65,28 +64,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use setup.cfg to decide about the optional subpackages tests and
-# toolkits_tests
-#
-cat setup.cfg.template > setup.cfg
-
-DISABLE_TESTS=$(echo "$DISABLE_TESTS"|cut -b 1|tr a-z A-Z)
-DISABLE_TK_TESTS=$(echo "$DISABLE_TK_TESTS"|cut -b 1|tr a-z A-Z)
-
-if [ "$DISABLE_TESTS" = "Y" ]
-then
- sed -i "s|#tests = True|tests = False|" setup.cfg
-else
- python -c "import nose, mock" > /dev/null 2>&1 || \
- { echo "ERROR: Missing requirements nose and/or mock!" && exit 1; }
-fi
+ENABLE_TESTS=$(echo "$ENABLE_TESTS"|cut -b 1|tr a-z A-Z)
-if [ "$DISABLE_TK_TESTS" = "Y" ]
-then
- sed -i "s|#toolkits_tests = auto|toolkits_tests = False|" setup.cfg
-elif [ "$DISABLE_TESTS" = "Y" ]
+if [ "$ENABLE_TESTS" = "Y" ]
then
- echo "ERROR: Cannot enable toolkits_tests if tests are disabled!" && exit 1
+ cat setup.cfg.template > setup.cfg
+ sed -i "s|#tests = False|tests = True|" setup.cfg
fi
# Use modified setupext.py to make sure that the build process gets
@@ -94,13 +77,13 @@ fi
#
cat "${CWD}/setupext.py" > setupext.py
-python setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
+python setup.py install --root $PKG > ${CWD}/SETUP.OUTPUT 2>&1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a INSTALL.rst MANIFEST.in README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install