aboutsummaryrefslogtreecommitdiff
path: root/libraries/libsunpinyin
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-06 19:46:26 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-07 08:38:03 +0700
commitf2d40d27591f7bf419dbf1fb4ba5151ad79d24cc (patch)
tree6f231d5cda80c999a549afdedc0105e6d772ca42 /libraries/libsunpinyin
parente9385885869c6b1166fa113f2a91b5eb2cd7e71b (diff)
downloadslackbuilds-f2d40d27591f7bf419dbf1fb4ba5151ad79d24cc.tar.xz
libraries/libsunpinyin: Removed (no maintainer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libsunpinyin')
-rw-r--r--libraries/libsunpinyin/README5
-rw-r--r--libraries/libsunpinyin/gcc47.patch22
-rw-r--r--libraries/libsunpinyin/libsunpinyin.SlackBuild95
-rw-r--r--libraries/libsunpinyin/libsunpinyin.info14
-rw-r--r--libraries/libsunpinyin/slack-desc19
5 files changed, 0 insertions, 155 deletions
diff --git a/libraries/libsunpinyin/README b/libraries/libsunpinyin/README
deleted file mode 100644
index e52b5dc1cc6b..000000000000
--- a/libraries/libsunpinyin/README
+++ /dev/null
@@ -1,5 +0,0 @@
-SunPinyin is a statistical language model based Chinese input method,
-which was firstly developed by Sun Beijing Globalization team.
-
-This is the base library for ibus-sunpinyin, scim-sunpinyin and
-xsunpinyin.
diff --git a/libraries/libsunpinyin/gcc47.patch b/libraries/libsunpinyin/gcc47.patch
deleted file mode 100644
index d3db5c1d9936..000000000000
--- a/libraries/libsunpinyin/gcc47.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur sunpinyin-2.0.3.orig/src/ime-core/ic_history.cpp sunpinyin-2.0.3/src/ime-core/ic_history.cpp
---- sunpinyin-2.0.3.orig/src/ime-core/ic_history.cpp 2011-02-18 04:39:52.000000000 +0100
-+++ sunpinyin-2.0.3/src/ime-core/ic_history.cpp 2012-09-18 05:32:14.687001314 +0200
-@@ -41,6 +41,7 @@
-
- #include <fcntl.h>
- #include <stdio.h>
-+#include <unistd.h>
- #include <stdint.h>
- #include <cassert>
- #include <sys/stat.h>
-diff -Naur sunpinyin-2.0.3.orig/src/lexicon/genPYT.cpp sunpinyin-2.0.3/src/lexicon/genPYT.cpp
---- sunpinyin-2.0.3.orig/src/lexicon/genPYT.cpp 2011-02-18 04:39:52.000000000 +0100
-+++ sunpinyin-2.0.3/src/lexicon/genPYT.cpp 2012-09-18 05:29:24.570735820 +0200
-@@ -37,6 +37,7 @@
-
- #include <locale.h>
- #include <stdlib.h>
-+#include <unistd.h>
-
- #include "pytrie.h"
- #include "pytrie_gen.h"
diff --git a/libraries/libsunpinyin/libsunpinyin.SlackBuild b/libraries/libsunpinyin/libsunpinyin.SlackBuild
deleted file mode 100644
index c9ba7ff33ab3..000000000000
--- a/libraries/libsunpinyin/libsunpinyin.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for sunpinyin
-
-# Written by Grissiom <chaos.proton@gmail.com>
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=libsunpinyin
-VERSION=${VERSION:-2.0.3}
-LMVER=${LMVER:-20120212}
-DIVER=${DIVER:-20120830}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf sunpinyin-$VERSION
-tar xvf $CWD/sunpinyin-$VERSION.tar.gz
-cd sunpinyin-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix building with gcc-4.7.x
-patch -p1 < $CWD/gcc47.patch
-
-# The dictionary and language model files are renamed with dates and the olds deleted
-# Fix this so it won't break build
-sed -i \
- -e "s|open-gram.*|ponce.cc/slackware/sources/repo/open-gram|" \
- -e "s|arpa\.tar|arpa-${LMVER}.tar|" \
- -e "s|utf8\.tar|utf8-${DIVER}.tar|" \
- raw/Makefile
-cp $CWD/{lm_sc.t3g.arpa-${LMVER},dict.utf8-${DIVER}}.tar.bz2 raw/ || true
-
-export CFLAGS="$SLKCFLAGS"
-export CXXFLAGS="$SLKCFLAGS"
-scons --prefix=/usr --libdir=/usr/lib$LIBDIRSUFFIX --libdatadir=/usr/lib$LIBDIRSUFFIX
-scons install --prefix=/usr --install-sandbox=$PKG --libdir=/usr/lib$LIBDIRSUFFIX --libdatadir=/usr/lib$LIBDIRSUFFIX
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING LGPL.LICENSE NEWS OPENSOLARIS.LICENSE README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libsunpinyin/libsunpinyin.info b/libraries/libsunpinyin/libsunpinyin.info
deleted file mode 100644
index 2048e37eb09c..000000000000
--- a/libraries/libsunpinyin/libsunpinyin.info
+++ /dev/null
@@ -1,14 +0,0 @@
-PRGNAM="libsunpinyin"
-VERSION="2.0.3"
-HOMEPAGE="https://github.com/sunpinyin/sunpinyin"
-DOWNLOAD="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/sunpinyin/sunpinyin-2.0.3.tar.gz \
- http://ponce.cc/slackware/sources/repo/open-gram/lm_sc.t3g.arpa-20120212.tar.bz2 \
- http://ponce.cc/slackware/sources/repo/open-gram/dict.utf8-20120830.tar.bz2"
-MD5SUM="bc1cd4d7d48a73276dfe4c9f5a434cc7 \
- 31dd2667d9a5cae9d2ecdacf2201ab13 \
- 52b9a47861bef707f65b682d52e8117f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Grissiom"
-EMAIL="chaos.proton@gmail.com"
diff --git a/libraries/libsunpinyin/slack-desc b/libraries/libsunpinyin/slack-desc
deleted file mode 100644
index 3d85749f7a54..000000000000
--- a/libraries/libsunpinyin/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-libsunpinyin: libsunpinyin (Chinese input method library)
-libsunpinyin:
-libsunpinyin: libSunPinyin is a statistical language model based Chinese input
-libsunpinyin: method library. which was firstly developed by Sun Beijing
-libsunpinyin: Globalization team.
-libsunpinyin:
-libsunpinyin: Homepage: https://github.com/sunpinyin/sunpinyin
-libsunpinyin:
-libsunpinyin:
-libsunpinyin:
-libsunpinyin: