aboutsummaryrefslogtreecommitdiff
path: root/libraries/json-py
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/json-py
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/json-py')
-rw-r--r--libraries/json-py/README6
-rw-r--r--libraries/json-py/json-py.SlackBuild84
-rw-r--r--libraries/json-py/json-py.info10
-rw-r--r--libraries/json-py/setup.py13
-rw-r--r--libraries/json-py/slack-desc19
5 files changed, 0 insertions, 132 deletions
diff --git a/libraries/json-py/README b/libraries/json-py/README
deleted file mode 100644
index 4c62e5fa90a8..000000000000
--- a/libraries/json-py/README
+++ /dev/null
@@ -1,6 +0,0 @@
-json-py is a simple, pure-python implementation of a JSON (http://json.org)
-reader and writer. JSON is used to exchange data across systems written
-in various languages. It is particularly suited to dynamic languages
-like Python, Javascript, etc. JSON = Javascript Object Notation implies
-it is suitable for AJAX applications that exchange data from servers to
-Javascript applications running on web browser clients.
diff --git a/libraries/json-py/json-py.SlackBuild b/libraries/json-py/json-py.SlackBuild
deleted file mode 100644
index 85e22f62ff44..000000000000
--- a/libraries/json-py/json-py.SlackBuild
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for json-py.
-#
-# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=json-py
-VERSION=3.4
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-SRCVERSION=3_4
-SRCNAM=json
-DOCS="license.txt readme.txt"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-mkdir $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$SRCVERSION.zip
-
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-# fix txts permissions
-chmod 644 *.txt
-
-# Add setup.py
-cat $CWD/setup.py > setup.py
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/json-py/json-py.info b/libraries/json-py/json-py.info
deleted file mode 100644
index 9e5619a76da1..000000000000
--- a/libraries/json-py/json-py.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="json-py"
-VERSION="3.4"
-HOMEPAGE="http://sourceforge.net/projects/json-py/"
-DOWNLOAD="http://downloads.sourceforge.net/sourceforge/json-py/json-py-3_4.zip"
-MD5SUM="921ebfede886a10ff32d6d4b4e216f8f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Marco Bonetti"
-EMAIL="sid77@slackware.it"
-APPROVED="dsomero"
diff --git a/libraries/json-py/setup.py b/libraries/json-py/setup.py
deleted file mode 100644
index 02f58089ac98..000000000000
--- a/libraries/json-py/setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
-from distutils.core import setup
-
-import json
-
-setup(name="json",
- version="3.4",
- description="JSON (http://json.org) reader and writer.",
- author="Patrick D. Logan",
- author_email="patrickdlogan@stardecisions.com",
- url = "http://sourceforge.net/projects/json-py/",
- py_modules=['json']
- )
-
diff --git a/libraries/json-py/slack-desc b/libraries/json-py/slack-desc
deleted file mode 100644
index d8a71b6f3110..000000000000
--- a/libraries/json-py/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-json-py: json-py (pure-python implementation of a JSON)
-json-py:
-json-py: json-py is a simple, pure-python implementation of a JSON
-json-py: (http://json.org) reader and writer.
-json-py:
-json-py:
-json-py:
-json-py:
-json-py:
-json-py:
-json-py: