aboutsummaryrefslogtreecommitdiff
path: root/libraries/cpprestsdk/cpprestsdk.patch
diff options
context:
space:
mode:
authorAndre Barboza <bmg.andre@gmail.com>2016-12-21 13:08:46 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-24 07:33:38 +0700
commit669bd94eac053c364de8f0ea8f07154339828497 (patch)
treedd287e52aec576c0d1bbedad0dd24a8971875732 /libraries/cpprestsdk/cpprestsdk.patch
parentf0df813362ee5f9e0843d15d1c264d3520f11ee5 (diff)
libraries/cpprestsdk: Added (C++ REST SDK library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/cpprestsdk/cpprestsdk.patch')
-rw-r--r--libraries/cpprestsdk/cpprestsdk.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/libraries/cpprestsdk/cpprestsdk.patch b/libraries/cpprestsdk/cpprestsdk.patch
new file mode 100644
index 000000000000..cd6035db8aee
--- /dev/null
+++ b/libraries/cpprestsdk/cpprestsdk.patch
@@ -0,0 +1,13 @@
+diff -ur cpprestsdk-2.9.0.old/Release/src/CMakeLists.txt cpprestsdk-2.9.0/Release/src/CMakeLists.txt
+--- cpprestsdk-2.9.0.old/Release/src/CMakeLists.txt 2016-10-18 17:30:28.000000000 -0200
++++ cpprestsdk-2.9.0/Release/src/CMakeLists.txt 2016-12-20 22:36:53.079208022 -0200
+@@ -147,7 +147,7 @@
+
+ install(
+ TARGETS cpprest
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ )
+ endif()