aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorroot <root@blackswan>2023-03-27 00:23:29 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-01 09:14:08 +0700
commit44f1e074bdcb7497cb77fe07a0a5b2204cdb5eb4 (patch)
tree95be402bc3161b21a50baa73ba466c81b9c6d50d /graphics
parentace9628dc4683f9e01161417fa6bc1085a658d92 (diff)
graphics/gallery-dl: Moved to network.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gallery-dl/README11
-rw-r--r--graphics/gallery-dl/gallery-dl.SlackBuild97
-rw-r--r--graphics/gallery-dl/gallery-dl.info10
-rw-r--r--graphics/gallery-dl/slack-desc19
4 files changed, 0 insertions, 137 deletions
diff --git a/graphics/gallery-dl/README b/graphics/gallery-dl/README
deleted file mode 100644
index 075afbb88867..000000000000
--- a/graphics/gallery-dl/README
+++ /dev/null
@@ -1,11 +0,0 @@
-gallery-dl (Command line image scraper)
-
-gallery-dl is a command-line program to download image galleries and
-collections from several image hosting sites. It is a cross-platform
-tool with many configuration options and powerful filenaming
-capabilities.
-
-Optional dependencies include yt-dlp/youtube-dl for video downloads and
-pysocks for SOCKS proxy support.
-
-
diff --git a/graphics/gallery-dl/gallery-dl.SlackBuild b/graphics/gallery-dl/gallery-dl.SlackBuild
deleted file mode 100644
index 3dfc9dce0c25..000000000000
--- a/graphics/gallery-dl/gallery-dl.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for gallery-dl
-
-# Copyright 2023 Samuel Young, MO, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=gallery-dl
-VERSION=${VERSION:-1.25.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cat $TMP/$PRGNAM-$VERSION/CHANGELOG.md > $PKG/usr/doc/$PRGNAM-$VERSION/CHANGELOG
-cat $TMP/$PRGNAM-$VERSION/LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/gallery-dl/gallery-dl.info b/graphics/gallery-dl/gallery-dl.info
deleted file mode 100644
index 13c7d7e1f353..000000000000
--- a/graphics/gallery-dl/gallery-dl.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="gallery-dl"
-VERSION="1.25.0"
-HOMEPAGE="https://github.com/mikf/gallery-dl"
-DOWNLOAD="https://github.com/mikf/gallery-dl/archive/v1.25.0/gallery-dl-1.25.0.tar.gz"
-MD5SUM="9578172bf94c073a262c44df6926b929"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Samuel Young"
-EMAIL="samyoung12788@gmail.com"
diff --git a/graphics/gallery-dl/slack-desc b/graphics/gallery-dl/slack-desc
deleted file mode 100644
index 9e18c191ca60..000000000000
--- a/graphics/gallery-dl/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-gallery-dl: gallery-dl (Command line image scraper)
-gallery-dl:
-gallery-dl: gallery-dl is a command-line program to download image galleries and
-gallery-dl: collections from several image hosting sites. It is a cross-platform
-gallery-dl: tool with many configuration options and powerful filenaming capabi-
-gallery-dl: lities.
-gallery-dl:
-gallery-dl: https://github.com/mikf/gallery-dl
-gallery-dl:
-gallery-dl:
-gallery-dl: