aboutsummaryrefslogtreecommitdiff
path: root/graphics/mangohud
diff options
context:
space:
mode:
authorSteven Voges <svoges.sbo@gmail.com>2023-04-21 09:19:31 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-21 09:19:31 +0700
commite3a9e4ce29248200123feb90c05f42f5122dc591 (patch)
tree49763865f1a67a791505148f3b4099b2f010235d /graphics/mangohud
parent5cb1985ed41118e17a42a8caca331f615aafa752 (diff)
graphics/mangohud: Updated for version 0.6.9.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/mangohud')
-rw-r--r--graphics/mangohud/README4
-rw-r--r--graphics/mangohud/mangohud.SlackBuild25
-rw-r--r--graphics/mangohud/mangohud.info16
3 files changed, 22 insertions, 23 deletions
diff --git a/graphics/mangohud/README b/graphics/mangohud/README
index 86a13f46e6b7..f0410f70b4e7 100644
--- a/graphics/mangohud/README
+++ b/graphics/mangohud/README
@@ -15,7 +15,3 @@ This SlackBuild defaults to building mangoapp as well. To
disable this behavior, pass MANGOAPP=false to the build
script. This removes the dependency on glfw3 and
nlohmann_json.
-
-If you would like multilib support, pass COMPAT32=yes to
-the build script. Please note that this only adds 32bit
-support for mangohud, NOT mangoapp.
diff --git a/graphics/mangohud/mangohud.SlackBuild b/graphics/mangohud/mangohud.SlackBuild
index 7f0af7689e56..a46883284c46 100644
--- a/graphics/mangohud/mangohud.SlackBuild
+++ b/graphics/mangohud/mangohud.SlackBuild
@@ -26,17 +26,15 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mangohud
SRCNAM=MangoHud
-VERSION=${VERSION:-0.6.9}
-SRCVER=${SRCVER:-0.6.9}
+VERSION=${VERSION:-0.6.9.1}
+SRCVER=${SRCVER:-0.6.9-1}
IMGUI=${IMGUI:-1.81}
-SPDLOG=${SPDLOG:-1.8.5}
VULKANHEADERS=${VULKANHEADERS:-1.2.158}
+XNVCTRL=${XNVCTRL:-disabled}
+MANGOAPP=${MANGOAPP:-true}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-COMPAT32=${COMPAT32:-no}
-XNVCTRL=${XNVCTRL:-disabled}
-MANGOAPP=${MANGOAPP:-true}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -69,6 +67,15 @@ else
LIBDIRSUFFIX=""
fi
+#Test for multilib
+COMPAT32=${COMPAT32@L}
+COMPATTMP="$( mktemp -d $TMP/compat32-test-XXXXXX )"
+cd $COMPATTMP
+echo "int main(void) {; return(0); }" > "$COMPATTMP/test.c"
+gcc -m32 "$COMPATTMP/test.c" -o /dev/null >/dev/null 2>&1 && COMPAT32=${COMPAT32:-yes}
+cd - >/dev/null 2>&1
+rm -rf "$COMPATTMP"
+
set -e
rm -rf $PKG
@@ -81,10 +88,7 @@ tar xvf $CWD/Vulkan-Headers-$VULKANHEADERS.tar.gz
unzip $CWD/vulkan-headers_$VULKANHEADERS-2_patch.zip
tar xvf $CWD/imgui-$IMGUI.tar.gz
unzip $CWD/imgui_$IMGUI-1_patch.zip
-tar xvf $CWD/spdlog-$SPDLOG.tar.gz
-unzip $CWD/spdlog_$SPDLOG-1_patch.zip
cd ..
-chown -R root:root .
#Slackware 15.0 ships meson 59.4, and mangohud requires 60.0, so we patch it.
sed -i "s/0.60.0/0.59.4/g" meson.build
@@ -92,6 +96,7 @@ sed -i "s/0.60.0/0.59.4/g" meson.build
sed -i "/install_tag/d" data/meson.build
sed -i "/install_tag/d" src/meson.build
+chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
@@ -111,6 +116,7 @@ cd build
--mandir=/usr/man \
--prefix=/usr \
--sysconfdir=/etc \
+ -Duse_system_spdlog=enabled \
-Dwith_xnvctrl=$XNVCTRL \
-Dmangoapp=$MANGOAPP
ninja
@@ -134,6 +140,7 @@ if [ "$COMPAT32" = "yes" ]; then
--mandir=/usr/man \
--prefix=/usr \
--sysconfdir=/etc \
+ -Duse_system_spdlog=enabled \
-Dwith_xnvctrl=$XNVCTRL \
-Dmangoapp=false
ninja
diff --git a/graphics/mangohud/mangohud.info b/graphics/mangohud/mangohud.info
index 22a8bebec238..2c5663769116 100644
--- a/graphics/mangohud/mangohud.info
+++ b/graphics/mangohud/mangohud.info
@@ -1,22 +1,18 @@
PRGNAM="mangohud"
-VERSION="0.6.9"
+VERSION="0.6.9.1"
HOMEPAGE="https://github.com/flightlessmango/MangoHud"
-DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.9/MangoHud-0.6.9.tar.gz \
+DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.9-1/MangoHud-0.6.9-1.tar.gz \
https://github.com/KhronosGroup/Vulkan-Headers/archive/v1.2.158/Vulkan-Headers-1.2.158.tar.gz \
https://github.com/mesonbuild/wrapdb/releases/download/vulkan-headers_1.2.158-2/vulkan-headers_1.2.158-2_patch.zip \
https://github.com/ocornut/imgui/archive/v1.81/imgui-1.81.tar.gz \
- https://github.com/mesonbuild/wrapdb/releases/download/imgui_1.81-1/imgui_1.81-1_patch.zip \
- https://github.com/gabime/spdlog/archive/v1.8.5/spdlog-1.8.5.tar.gz \
- https://github.com/mesonbuild/wrapdb/releases/download/spdlog_1.8.5-1/spdlog_1.8.5-1_patch.zip"
-MD5SUM="da45749b0052832d6d40e119f8a64a5b \
+ https://github.com/mesonbuild/wrapdb/releases/download/imgui_1.81-1/imgui_1.81-1_patch.zip"
+MD5SUM="572b748eabd3b61443301991b177eb9b \
44245ecbc0c428b1c8db58089eb59821 \
4c47a8c306c495f94d2ec2fe8f611178 \
9b48ac38829b538233f99c0aa8cacf50 \
- ea266ae77ac14290ceb2eafa56c1de83 \
- 8755cdbc857794730a022722a66d431a \
- 73a3c3149a4aa2b105aeef3a1d45bcb0"
+ ea266ae77ac14290ceb2eafa56c1de83"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="glfw3 nlohmann_json"
+REQUIRES="glfw3 nlohmann_json spdlog"
MAINTAINER="Steven Voges"
EMAIL="svoges.sbo@gmail.com"