aboutsummaryrefslogtreecommitdiff
path: root/gis
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-31 19:48:29 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-06-01 01:15:45 +0700
commit8d2e2e9be5cac29a3d1bb2702822b63bbc109698 (patch)
tree8aa7b1b7c156c88c80f89e4f56adb36d05c9ac32 /gis
parent805a289167b61e9b18e50e8e3b5631f70b5a57cf (diff)
gis/gdal: Patched for newer poppler.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/gdal/gdal.SlackBuild5
-rw-r--r--gis/gdal/poppler.patch23
2 files changed, 27 insertions, 1 deletions
diff --git a/gis/gdal/gdal.SlackBuild b/gis/gdal/gdal.SlackBuild
index b772003aadb3a..c18ddc7e6676b 100644
--- a/gis/gdal/gdal.SlackBuild
+++ b/gis/gdal/gdal.SlackBuild
@@ -30,7 +30,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gdal
VERSION=${VERSION:-3.8.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -96,6 +96,9 @@ if [ ${JAVA:-no} = "no" ]; then
WITHLIST+=" -DBUILD_JAVA_BINDINGS:BOOL=OFF"
fi
+# Patch for newer poppler
+patch -p1 < $CWD/poppler.patch
+
mkdir build
( cd build
diff --git a/gis/gdal/poppler.patch b/gis/gdal/poppler.patch
new file mode 100644
index 0000000000000..837a50f6b8253
--- /dev/null
+++ b/gis/gdal/poppler.patch
@@ -0,0 +1,23 @@
+From 60dcddbf5fab917338caf433b3e7dca283cf9720 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Thu, 4 Apr 2024 17:48:33 +0200
+Subject: [PATCH] Fix build with Poppler 24.05 (unreleased yet)
+
+---
+ frmts/pdf/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/frmts/pdf/CMakeLists.txt b/frmts/pdf/CMakeLists.txt
+index 9b9a1898a730..bcb19c3aa24c 100644
+--- a/frmts/pdf/CMakeLists.txt
++++ b/frmts/pdf/CMakeLists.txt
+@@ -54,6 +54,9 @@ if (GDAL_USE_POPPLER)
+ if ("${Poppler_VERSION_MINOR}" MATCHES "0?[0-9]+")
+ string(REGEX REPLACE "0?([0-9]+)" "\\1" Poppler_VERSION_MINOR ${Poppler_VERSION_MINOR})
+ endif ()
++ if (Poppler_VERSION_STRING VERSION_GREATER_EQUAL "24.05")
++ target_compile_features(gdal_PDF PRIVATE cxx_std_20)
++ endif ()
+ target_compile_definitions(gdal_PDF PRIVATE -DHAVE_POPPLER -DPOPPLER_MAJOR_VERSION=${Poppler_VERSION_MAJOR}
+ -DPOPPLER_MINOR_VERSION=${Poppler_VERSION_MINOR})
+ endif ()