aboutsummaryrefslogtreecommitdiff
path: root/gis
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2023-06-24 00:51:32 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-02 23:21:13 +0700
commit5751eb4adff7c0f87e0088883cc8f632b28b23ff (patch)
tree99d863fca585177e6ccfc79dea0dd9250ab40125 /gis
parent08b8acf5abb21d651af5fa361624b06bf2194f73 (diff)
downloadslackbuilds-5751eb4adff7c0f87e0088883cc8f632b28b23ff.tar.xz
gis/python3-netcdf4-python: Updated for version 1.6.4.
- added dep python3-setuptools-opt - patch for oldest-supported-numpy requirement Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild33
-rw-r--r--gis/python3-netcdf4-python/python3-netcdf4-python.info8
2 files changed, 19 insertions, 22 deletions
diff --git a/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild b/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
index 908be04c4e58..1ae1f1e3549e 100644
--- a/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
+++ b/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-netcdf4-python
-# Copyright 2022 - Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2022-2023 - Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,13 +25,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-netcdf4-python
-VERSION=${VERSION:-1.6.2}
+VERSION=${VERSION:-1.6.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=netcdf4-python
-SRCVER=${VERSION}
+SRCVER=${VERSION}rel
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -50,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -79,7 +65,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Fixing numpy dependency check in pyproject.toml:
+# oldest-supported-numpy has a strict check and doesn't support newer version
+# so we replace it. The alternative is to add --skip-dependency-check to tbe
+# build line but this is not deemed optimal.
+sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
+
+# Requires newer version of setuptools than available in -stable. Has not
+# effect on -current
+export PYTHONPATH=/opt/python3.9/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/gis/python3-netcdf4-python/python3-netcdf4-python.info b/gis/python3-netcdf4-python/python3-netcdf4-python.info
index 199da885b746..d9ffbff76ae7 100644
--- a/gis/python3-netcdf4-python/python3-netcdf4-python.info
+++ b/gis/python3-netcdf4-python/python3-netcdf4-python.info
@@ -1,10 +1,10 @@
PRGNAM="python3-netcdf4-python"
-VERSION="1.6.2"
+VERSION="1.6.4"
HOMEPAGE="http://unidata.github.io/netcdf4-python/"
-DOWNLOAD="https://github.com/Unidata/netcdf4-python/archive/v1.6.2/netcdf4-python-1.6.2.tar.gz"
-MD5SUM="8a1dd0489bc56a982014b0dc86d1f3c2"
+DOWNLOAD="https://github.com/Unidata/netcdf4-python/archive/v1.6.4rel/netcdf4-python-1.6.4rel.tar.gz"
+MD5SUM="f377d9da6641272c2dc435ceab1c6209"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="netcdf python3-cftime"
+REQUIRES="netcdf python3-cftime python3-setuptools-opt"
MAINTAINER="ArTourter"
EMAIL="artourter@gmail.com"