aboutsummaryrefslogtreecommitdiff
path: root/gis
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2024-08-23 22:03:14 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-25 07:07:55 +0700
commit9f6a5f48f0c365ec1aea99410f78e7bac1234d57 (patch)
treedc500d243d639836c07fa41df600c3f95f530674 /gis
parenta0b6fcfc1186f8b01d32c4e3e549ff7ec0decff3 (diff)
gis/python3-pyproj: Updated for version 3.6.1.
using pypi source tarball change pyproject.toml to remove cython3 requirement add [tool.setuptool_scm] section Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/python3-pyproj/python3-pyproj.SlackBuild17
-rw-r--r--gis/python3-pyproj/python3-pyproj.info6
2 files changed, 14 insertions, 9 deletions
diff --git a/gis/python3-pyproj/python3-pyproj.SlackBuild b/gis/python3-pyproj/python3-pyproj.SlackBuild
index 55256a46f3538..246cf0c474c88 100644
--- a/gis/python3-pyproj/python3-pyproj.SlackBuild
+++ b/gis/python3-pyproj/python3-pyproj.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pyproj
# Copyright 2013-2021 Benjamin Trigona-Harany
-# Copyright 2021-2023 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2021-2024 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproj
-VERSION=${VERSION:-3.6.0}
+VERSION=${VERSION:-3.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,14 +77,19 @@ tar xvf $CWD/$SRCNAM-${VERSION}.tar.gz
cd $SRCNAM-${VERSION}
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages
+# cython3 does not seem to be actually needed.
+# Adding setuptools-scm info to get rid of spurious messages when
+# python3-setuptools-scm-opt is installed
+#
+sed -i 's/cython>=3/cython/' pyproject.toml
+echo '[tool.setuptools_scm]' >> pyproject.toml
+
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl
diff --git a/gis/python3-pyproj/python3-pyproj.info b/gis/python3-pyproj/python3-pyproj.info
index f093177f12528..a167cd223c517 100644
--- a/gis/python3-pyproj/python3-pyproj.info
+++ b/gis/python3-pyproj/python3-pyproj.info
@@ -1,8 +1,8 @@
PRGNAM="python3-pyproj"
-VERSION="3.6.0"
+VERSION="3.6.1"
HOMEPAGE="https://github.com/pyproj4/pyproj"
-DOWNLOAD="https://github.com/pyproj4/pyproj/archive/3.6.0/pyproj-3.6.0.tar.gz"
-MD5SUM="dd28c4d2b030431ebde1c96b118f55cd"
+DOWNLOAD="https://files.pythonhosted.org/packages/7d/84/2b39bbf888c753ea48b40d47511548c77aa03445465c35cc4c4e9649b643/pyproj-3.6.1.tar.gz"
+MD5SUM="09a67b757bc473b47fb2e247b9994228"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="proj python3-setuptools-opt"