aboutsummaryrefslogtreecommitdiff
path: root/gis
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2024-07-05 23:45:30 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-07-07 10:40:51 +0700
commit585d57219f640ef9bee3ddefba48b614b6344126 (patch)
tree171c12e6bced5b2e38c6acf3929cefc7925bf6fa /gis
parent2ee362ff9cacba380d775f2b918e309f3be28cc1 (diff)
gis/Fiona: Update for 1.9.4.post1 (+new maintainer)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/Fiona/Fiona.SlackBuild31
-rw-r--r--gis/Fiona/Fiona.info12
-rw-r--r--gis/Fiona/README3
3 files changed, 20 insertions, 26 deletions
diff --git a/gis/Fiona/Fiona.SlackBuild b/gis/Fiona/Fiona.SlackBuild
index b1cfbb9b20db7..689b4e74506c6 100644
--- a/gis/Fiona/Fiona.SlackBuild
+++ b/gis/Fiona/Fiona.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for Fiona
# Copyright 2013-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Fiona
-VERSION=${VERSION:-1.8.20}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.9.4.post1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -79,7 +63,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# remove requirement
+sed -i '/oldest-supported-numpy/d' pyproject.toml
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/gis/Fiona/Fiona.info b/gis/Fiona/Fiona.info
index e0f3d74acb317..a5b23cc9d9010 100644
--- a/gis/Fiona/Fiona.info
+++ b/gis/Fiona/Fiona.info
@@ -1,10 +1,10 @@
PRGNAM="Fiona"
-VERSION="1.8.20"
+VERSION="1.9.4.post1"
HOMEPAGE="https://github.com/Toblerity/Fiona"
-DOWNLOAD="https://github.com/Toblerity/Fiona/archive/1.8.20/Fiona-1.8.20.tar.gz"
-MD5SUM="186f39b90b8191c37745ceafacceda94"
+DOWNLOAD="https://github.com/Toblerity/Fiona/archive/1.9.4.post1/Fiona-1.9.4.post1.tar.gz"
+MD5SUM="8c22085e3af1e69d6e4fff313c976ff5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gdal munch python3-attrs click-plugins cligj"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="gdal munch python3-attrs click-plugins cligj python-importlib_metadata"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"
diff --git a/gis/Fiona/README b/gis/Fiona/README
index ad7dc450bdf72..58932900089ee 100644
--- a/gis/Fiona/README
+++ b/gis/Fiona/README
@@ -9,3 +9,6 @@ iterators instead of classes specific to OGR. Fiona can read and write
real-world data using multi-layered GIS formats and zipped virtual
file systems and integrates readily with other Python GIS packages
such as pyproj, Rtree and Shapely.
+
+Fiona 1.9.4.post1 is the last available version for Slackware 15.0.
+Newer versions require a newer Cython (at >= 3.0.2).