aboutsummaryrefslogtreecommitdiff
path: root/gis/pytrainer/pytrainer.SlackBuild
diff options
context:
space:
mode:
authorKyle Guinn <elyk03@gmail.com>2024-01-12 22:26:24 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-20 09:16:26 +0700
commit99d6be0343b8b02f4882cb5f064ec7a92a7ac97d (patch)
tree9743f69bf99e85d80cc65d6896edd25e84ce057a /gis/pytrainer/pytrainer.SlackBuild
parent32afd0b34349b197379eec7f7cc6b5f89ffab392 (diff)
gis/pytrainer: Updated for version 2.2.1
Signed-off-by: Kyle Guinn <elyk03@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/pytrainer/pytrainer.SlackBuild')
-rw-r--r--gis/pytrainer/pytrainer.SlackBuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/gis/pytrainer/pytrainer.SlackBuild b/gis/pytrainer/pytrainer.SlackBuild
index 5cde47db156a7..7165cf00332ab 100644
--- a/gis/pytrainer/pytrainer.SlackBuild
+++ b/gis/pytrainer/pytrainer.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Pytrainer
-# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2014-2024 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pytrainer
-VERSION=${VERSION:-2.0.2}
+VERSION=${VERSION:-2.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -63,7 +60,7 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION