aboutsummaryrefslogtreecommitdiff
path: root/gis/python3-pyproj
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2022-03-09 12:33:18 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 21:29:30 +0700
commit8f0fea2072bf7f3f9cb44d31065ada1de24b0e49 (patch)
tree7ab38744f6e1d4f95702d15b242299746b83b05a /gis/python3-pyproj
parent4064e9ea0b98bb9cac5f1544d2593db907884d4c (diff)
downloadslackbuilds-8f0fea2072bf7f3f9cb44d31065ada1de24b0e49.tar.xz
gis/python3-pyproj: renamed from gis/pyproj
Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/python3-pyproj')
-rw-r--r--gis/python3-pyproj/README16
-rw-r--r--gis/python3-pyproj/python3-pyproj.SlackBuild100
-rw-r--r--gis/python3-pyproj/python3-pyproj.info10
-rw-r--r--gis/python3-pyproj/slack-desc19
4 files changed, 145 insertions, 0 deletions
diff --git a/gis/python3-pyproj/README b/gis/python3-pyproj/README
new file mode 100644
index 000000000000..b86dd367a69a
--- /dev/null
+++ b/gis/python3-pyproj/README
@@ -0,0 +1,16 @@
+Performs cartographic transformations and geodetic computations.
+
+The Proj class can convert from geographic (longitude,latitude) to native map
+projection (x,y) coordinates and vice versa, or from one map projection
+coordinate system directly to another.
+
+The Geod class can perform forward and inverse geodetic, or Great Circle,
+computations. The forward computation involves determining latitude, longitude
+and back azimuth of a terminus point given the latitude and longitude of an
+initial point, plus azimuth and distance. The inverse computation involves
+determining the forward and back azimuths and distance given the latitudes and
+longitudes of an initial and terminus point.
+
+Input coordinates can be given as python arrays, lists/tuples, scalars or
+numpy/Numeric/numarray arrays. Optimized for objects that support the Python
+buffer protocol (regular python and numpy array objects).
diff --git a/gis/python3-pyproj/python3-pyproj.SlackBuild b/gis/python3-pyproj/python3-pyproj.SlackBuild
new file mode 100644
index 000000000000..e962a49b1503
--- /dev/null
+++ b/gis/python3-pyproj/python3-pyproj.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for pyproj
+
+# Copyright 2013-2021 Benjamin Trigona-Harany
+# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pyproj
+VERSION=${VERSION:-3.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=pyproj
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-${VERSION}
+tar xvf $CWD/$SRCNAM-${VERSION}.tar.gz
+cd $SRCNAM-${VERSION}
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/python3-pyproj/python3-pyproj.info b/gis/python3-pyproj/python3-pyproj.info
new file mode 100644
index 000000000000..1329a6caea4e
--- /dev/null
+++ b/gis/python3-pyproj/python3-pyproj.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pyproj"
+VERSION="3.3.0"
+HOMEPAGE="https://github.com/pyproj4/pyproj"
+DOWNLOAD="https://github.com/pyproj4/pyproj/archive/3.3.0/pyproj-3.3.0.tar.gz"
+MD5SUM="c2374e4b97f9caa0a3b1b3f36f2fee61"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="proj"
+MAINTAINER="ArTourter"
+EMAIL="artourter@gmail.com"
diff --git a/gis/python3-pyproj/slack-desc b/gis/python3-pyproj/slack-desc
new file mode 100644
index 000000000000..4a0ae0947b3b
--- /dev/null
+++ b/gis/python3-pyproj/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pyproj: pyproj (Python interface to the PROJ.4 library)
+python3-pyproj:
+python3-pyproj: pyproj can convert from geographic (longitude,latitude) to native
+python3-pyproj: map projection (x,y) coordinates and vice versa, or from one map
+python3-pyproj: projection coordinate system directly to another.
+python3-pyproj:
+python3-pyproj: Homepage: http://code.google.com/p/pyproj/
+python3-pyproj:
+python3-pyproj:
+python3-pyproj:
+python3-pyproj: