aboutsummaryrefslogtreecommitdiff
path: root/games/m64py/m64py.SlackBuild
diff options
context:
space:
mode:
authorM.Dinslage <daedra1980@gmail.com>2021-07-31 01:13:34 -0500
committerRobby Workman <rworkman@slackbuilds.org>2021-08-01 04:20:54 -0500
commit064d0f8d2261e3ec6502ac3be63d6d4a2eab310a (patch)
tree54019b34ba58f6667072fd7824fc0691b8658085 /games/m64py/m64py.SlackBuild
parent288e994678b37294db6129b2932af9c6e2716ce9 (diff)
games/m64py: Build using qt5
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'games/m64py/m64py.SlackBuild')
-rw-r--r--games/m64py/m64py.SlackBuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/games/m64py/m64py.SlackBuild b/games/m64py/m64py.SlackBuild
index eec81bf999bd0..16248d4ad140f 100644
--- a/games/m64py/m64py.SlackBuild
+++ b/games/m64py/m64py.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for m64py
-# Copyright 2015 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
+# Copyright 2021 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -34,6 +34,7 @@ if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -74,19 +75,19 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS CHANGELOG COPYING LICENSES PKG-INFO README.rst \
+ AUTHORS CHANGELOG LICENSES README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild