aboutsummaryrefslogtreecommitdiff
path: root/games/jfsw/patches
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2018-07-13 22:41:52 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-07-17 07:15:49 +0700
commit2c0e839923b6853a42533691393dea9629d9fd5e (patch)
tree58f9f71f0a3d7e7b9d866933f2e4907561431bec /games/jfsw/patches
parent70c013179db63be17ff6a1e7b8d797688aa02eb8 (diff)
games/jfsw: Enhance script and documentation.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'games/jfsw/patches')
-rw-r--r--games/jfsw/patches/disable_fluid.diff12
-rw-r--r--games/jfsw/patches/disable_sdl2.diff31
-rw-r--r--games/jfsw/patches/dont_use_jack.diff14
-rw-r--r--games/jfsw/patches/fixsegfault.diff12
-rw-r--r--games/jfsw/patches/sdl1_fix.diff12
-rw-r--r--games/jfsw/patches/sdl_cdrom_fix.diff20
6 files changed, 101 insertions, 0 deletions
diff --git a/games/jfsw/patches/disable_fluid.diff b/games/jfsw/patches/disable_fluid.diff
new file mode 100644
index 0000000000000..970e8bd67aacc
--- /dev/null
+++ b/games/jfsw/patches/disable_fluid.diff
@@ -0,0 +1,12 @@
+diff -Naur jfsw.orig/jfaudiolib/Makefile.shared jfsw/jfaudiolib/Makefile.shared
+--- jfsw.orig/jfaudiolib/Makefile.shared 2017-02-02 07:22:54.000000000 -0500
++++ jfsw/jfaudiolib/Makefile.shared 2018-07-12 15:25:01.996310856 -0400
+@@ -30,8 +30,4 @@
+ JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs alsa)
+ JFAUDIOLIB_LDFLAGS+=-lpthread
+ endif
+- ifeq (yes,$(shell pkg-config --exists fluidsynth && echo yes))
+- JFAUDIOLIB_HAVE_FLUIDSYNTH=1
+- JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs fluidsynth)
+- endif
+ endif
diff --git a/games/jfsw/patches/disable_sdl2.diff b/games/jfsw/patches/disable_sdl2.diff
new file mode 100644
index 0000000000000..425402882671e
--- /dev/null
+++ b/games/jfsw/patches/disable_sdl2.diff
@@ -0,0 +1,31 @@
+diff -Naur jfsw.orig2/jfaudiolib/Makefile.shared jfsw/jfaudiolib/Makefile.shared
+--- jfsw.orig2/jfaudiolib/Makefile.shared 2018-07-12 15:44:51.443280637 -0400
++++ jfsw/jfaudiolib/Makefile.shared 2018-07-12 15:43:41.666282410 -0400
+@@ -16,15 +16,10 @@
+ JFAUDIOLIB_HAVE_VORBIS=1
+ JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs vorbisfile)
+ endif
+- ifeq (yes,$(shell pkg-config --exists sdl2 && echo yes))
+- JFAUDIOLIB_HAVE_SDL=2
+- JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs sdl2)
+- else
+ ifeq (yes,$(shell pkg-config --exists sdl && echo yes))
+ JFAUDIOLIB_HAVE_SDL=1
+ JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs sdl)
+ endif
+- endif
+ ifeq (yes,$(shell pkg-config --exists alsa && echo yes))
+ JFAUDIOLIB_HAVE_ALSA=1
+ JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs alsa)
+diff -Naur jfsw.orig2/jfbuild/Makefile.shared jfsw/jfbuild/Makefile.shared
+--- jfsw.orig2/jfbuild/Makefile.shared 2017-02-04 02:45:28.000000000 -0500
++++ jfsw/jfbuild/Makefile.shared 2018-07-12 15:51:08.320271062 -0400
+@@ -9,7 +9,7 @@
+ GLLIBLIN=-lGL
+
+ SDLCONFIG=$(shell which sdl-config)
+-SDL2CONFIG=$(shell which sdl2-config)
++SDL2CONFIG=
+
+ # Path to the included libsquish
+ LIBSQUISH=libsquish
diff --git a/games/jfsw/patches/dont_use_jack.diff b/games/jfsw/patches/dont_use_jack.diff
new file mode 100644
index 0000000000000..35dcbdb0172a5
--- /dev/null
+++ b/games/jfsw/patches/dont_use_jack.diff
@@ -0,0 +1,14 @@
+diff -Naur jfsw.orig/jfaudiolib/src/driver_fluidsynth.c jfsw/jfaudiolib/src/driver_fluidsynth.c
+--- jfsw.orig/jfaudiolib/src/driver_fluidsynth.c 2017-02-02 07:22:54.000000000 -0500
++++ jfsw/jfaudiolib/src/driver_fluidsynth.c 2018-07-12 05:08:37.119250512 -0400
+@@ -342,6 +342,10 @@
+ return FSynthErr_Error;
+ }
+
++ /* 20180712 bkw: don't try to use JACK (it doesn't work) */
++ if(fluid_settings_str_equal(fluidsettings, "audio.driver", "jack"))
++ fluid_settings_setstr(fluidsettings, "audio.driver", "alsa");
++
+ fluidaudiodriver = new_fluid_audio_driver(fluidsettings, fluidsynth);
+ if (!fluidsettings) {
+ FluidSynthDrv_MIDI_Shutdown();
diff --git a/games/jfsw/patches/fixsegfault.diff b/games/jfsw/patches/fixsegfault.diff
new file mode 100644
index 0000000000000..9290ffef9613d
--- /dev/null
+++ b/games/jfsw/patches/fixsegfault.diff
@@ -0,0 +1,12 @@
+diff -Naur jfsw.orig/src/menus.c jfsw/src/menus.c
+--- jfsw.orig/src/menus.c 2017-03-24 23:22:17.000000000 -0400
++++ jfsw/src/menus.c 2018-07-10 22:51:52.032019948 -0400
+@@ -2540,7 +2540,7 @@
+ CONTROL_ClearUserInput(&mnu_input);
+ CONTROL_GetUserInput(&mnu_input);
+
+- if (KB_KeyPressed(sc_Y) || KB_KeyPressed(sc_Enter) || mnu_input.button0)
++ if (KB_KeyPressed(sc_Y) || KB_KeyPressed(sc_Enter))
+ return (TRUE);
+ else
+ return (FALSE);
diff --git a/games/jfsw/patches/sdl1_fix.diff b/games/jfsw/patches/sdl1_fix.diff
new file mode 100644
index 0000000000000..1e68caab33765
--- /dev/null
+++ b/games/jfsw/patches/sdl1_fix.diff
@@ -0,0 +1,12 @@
+diff -Naur jfsw.orig/jfaudiolib/Makefile.shared jfsw/jfaudiolib/Makefile.shared
+--- jfsw.orig/jfaudiolib/Makefile.shared 2017-02-02 07:22:54.000000000 -0500
++++ jfsw/jfaudiolib/Makefile.shared 2018-07-12 15:31:55.593300348 -0400
+@@ -22,7 +22,7 @@
+ else
+ ifeq (yes,$(shell pkg-config --exists sdl && echo yes))
+ JFAUDIOLIB_HAVE_SDL=1
+- JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs sdl1)
++ JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs sdl)
+ endif
+ endif
+ ifeq (yes,$(shell pkg-config --exists alsa && echo yes))
diff --git a/games/jfsw/patches/sdl_cdrom_fix.diff b/games/jfsw/patches/sdl_cdrom_fix.diff
new file mode 100644
index 0000000000000..bffad4a76b272
--- /dev/null
+++ b/games/jfsw/patches/sdl_cdrom_fix.diff
@@ -0,0 +1,20 @@
+diff -Naur jfsw.orig/jfaudiolib/src/driver_sdl.c jfsw/jfaudiolib/src/driver_sdl.c
+--- jfsw.orig/jfaudiolib/src/driver_sdl.c 2017-02-02 07:22:54.000000000 -0500
++++ jfsw/jfaudiolib/src/driver_sdl.c 2018-07-12 17:08:14.907153516 -0400
+@@ -375,6 +375,7 @@
+ int SDLDrv_CD_Init(void)
+ {
+ #if (SDL_MAJOR_VERSION == 1)
++ CDstatus status;
+ Uint32 inited;
+ Uint32 err = 0;
+ int i;
+@@ -407,6 +408,8 @@
+ return SDLErr_Error;
+ }
+
++ status = SDL_CDStatus(CDRom);
++
+ fprintf(stderr, "SDL_CD: numtracks: %d\n", CDRom->numtracks);
+ for (i = 0; i < CDRom->numtracks; i++) {
+ fprintf(stderr, "SDL_CD: track %d - %s, %dsec\n",