aboutsummaryrefslogtreecommitdiff
path: root/games/gzdoom/gzdoom.SlackBuild
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2021-10-10 16:07:58 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-13 00:52:40 +0700
commit5c2345a2601b37d7ba8c1d8ca629e4a02d98ed6e (patch)
treed237437943150a244925df3ad2e8eaab3b71e98c /games/gzdoom/gzdoom.SlackBuild
parentdd0b4fd2d3838821a136bbc8c2e7c55f885e9bac (diff)
games/gzdoom: Updated for version 4.7.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/gzdoom/gzdoom.SlackBuild')
-rw-r--r--games/gzdoom/gzdoom.SlackBuild15
1 files changed, 1 insertions, 14 deletions
diff --git a/games/gzdoom/gzdoom.SlackBuild b/games/gzdoom/gzdoom.SlackBuild
index 1f5a823aa1848..780f2f6f318ee 100644
--- a/games/gzdoom/gzdoom.SlackBuild
+++ b/games/gzdoom/gzdoom.SlackBuild
@@ -36,7 +36,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gzdoom
-VERSION=${VERSION:-4.5.0}
+VERSION=${VERSION:-4.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,9 +49,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -95,15 +92,6 @@ sed -i '/COMMAND.*UpdateRevision/s,^,# ,' src/CMakeLists.txt
echo "#define GIT_HASH \"release\""
echo "#define GIT_TIME __DATE__" ) > src/gitinfo.h
-# 4.5.0 uses "if constexpr", which is a c++17 feature not supported by
-# our compiler from 2016.
-[ -e $CWD/compilefix.$VERSION.diff ] && \
- patch -p1 < $CWD/compilefix.$VERSION.diff
-
-# 20201107 bkw: 4.5.0 needs this, patch comes from upstream git. Thanks
-# to Steven Voges on the mailing list for pointing it out to me.
-patch -p1 < $CWD/fix_zipdir.diff
-
# 3.1.0 started needing -DNDEBUG. Using ld.gold speeds up the final link
# enough to be worth using (saves 17+ sec on my test box).
SLKCFLAGS="$SLKCFLAGS -DNDEBUG -fuse-ld=gold"
@@ -115,7 +103,6 @@ sed -i '1i#include <cmath>' \
mkdir -p build
cd build
- export "PATH=/opt/cmake-202x/bin:$PATH"
cmake \
-DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS -DSHARE_DIR=\\\"/usr/share/games/doom\\\"" \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DSHARE_DIR=\\\"/usr/share/games/doom\\\"" \