aboutsummaryrefslogtreecommitdiff
path: root/games/gzdoom/gzdoom.SlackBuild
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2020-11-08 14:59:47 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2020-11-14 17:16:44 +0700
commit3b23d039fa5fd66b0a1497237f0db8210f5947a3 (patch)
tree8800013cfdc153a73638306ea3a81b3bbe377c80 /games/gzdoom/gzdoom.SlackBuild
parentf47144dfbf9c65a917069d25d0a46bafd17f7e25 (diff)
games/gzdoom: Updated for version 4.5.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/gzdoom/gzdoom.SlackBuild')
-rw-r--r--games/gzdoom/gzdoom.SlackBuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/games/gzdoom/gzdoom.SlackBuild b/games/gzdoom/gzdoom.SlackBuild
index 33b640cdf4e10..c4e6691acabbf 100644
--- a/games/gzdoom/gzdoom.SlackBuild
+++ b/games/gzdoom/gzdoom.SlackBuild
@@ -6,6 +6,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20201107 bkw: Updated for 4.5.0.
# 20201027 bkw:
# - Updated for 4.4.2.
# - Add new zmusic dep.
@@ -32,7 +33,7 @@
# supported as "gzdoom-legacy" for those that need them.
PRGNAM=gzdoom
-VERSION=${VERSION:-4.4.2}
+VERSION=${VERSION:-4.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -83,10 +84,15 @@ sed -i '/COMMAND.*UpdateRevision/s,^,# ,' src/CMakeLists.txt
echo "#define GIT_HASH \"release\""
echo "#define GIT_TIME __DATE__" ) > src/gitinfo.h
-# This isn't currently used, but was in the past, and will be again I'm sure.
+# 4.5.0 uses "if constexpr", which is a c++17 feature not supported by
+# our compiler from 2016.
[ -e $CWD/compilefix.$VERSION.diff ] && \
patch -p1 < $CWD/compilefix.$VERSION.diff
+# 20201107 bkw: 4.5.0 needs this, patch comes from upstream git. Thanks
+# to Steven Voges on the mailing list for pointing it out to me.
+patch -p1 < $CWD/fix_zipdir.diff
+
# 3.1.0 started needing -DNDEBUG. Using ld.gold speeds up the final link
# enough to be worth using (saves 17+ sec on my test box).
SLKCFLAGS="$SLKCFLAGS -DNDEBUG -fuse-ld=gold"
@@ -98,7 +104,7 @@ sed -i '1i#include <cmath>' \
mkdir -p build
cd build
- cmake \
+ /opt/cmake-202x/bin/cmake \
-DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS -DSHARE_DIR=\\\"/usr/share/games/doom\\\"" \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DSHARE_DIR=\\\"/usr/share/games/doom\\\"" \
-DINSTALL_DOCS_PATH=doc/$PRGNAM-$VERSION \