aboutsummaryrefslogtreecommitdiff
path: root/games/fceux/fceux.SlackBuild
diff options
context:
space:
mode:
authorM.Dinslage <daedra1980@gmail.com>2021-07-25 21:38:29 -0500
committerRobby Workman <rworkman@slackbuilds.org>2021-07-25 21:38:29 -0500
commit65f5fd0ab0479920c068fca4253452d82f2f1905 (patch)
tree82a3a0551068524038a564658649a3a22cacd466 /games/fceux/fceux.SlackBuild
parentf5226a274864d9d8193291809c1db20cc68fdfcb (diff)
games/fceux: Updated for version 2.4.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'games/fceux/fceux.SlackBuild')
-rw-r--r--games/fceux/fceux.SlackBuild63
1 files changed, 31 insertions, 32 deletions
diff --git a/games/fceux/fceux.SlackBuild b/games/fceux/fceux.SlackBuild
index 0147dcfb81767..d8ab3875be41c 100644
--- a/games/fceux/fceux.SlackBuild
+++ b/games/fceux/fceux.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for fceux
-# Copyright 2016 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
+# Copyright 2021 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,18 +22,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=fceux
-VERSION=${VERSION:-2.2.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.4.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -51,17 +50,17 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="'-O2', '-march=i486', '-mtune=i686'"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="'-O2', '-march=i686', '-mtune=i686'"
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="'-O2', '-fPIC'"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="'-O2'"
+ SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -71,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.src.tar.?z*
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -80,23 +79,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix building with python3
-patch -p1 < $CWD/scons-python3.patch
-
-# Set our CFLAGS, move man pages, disable debub symbols
-sed -i \
- -e "s|'-Wall'|${SLKCFLAGS}, '-Wall'|" \
- -e "s|/share/man/man6/|/man/man6/|" \
- -e "s|/share/man/man6/|/man/man6/|" \
- -e "s|symbols', 1|symbols', 0|" \
- -e "s|release', 0|release', 1|" \
- SConstruct
-
-scons install -i --prefix=$PKG/usr
-
-# Delete low res icon and replace below, also delete unneeded .dll files
-rm -f $PKG/usr/share/pixmaps/fceux.png
-rm -f $PKG/usr/share/$PRGNAM/*.dll
+# Fix man pages
+sed -i 's,share/man/man6,man/man6,g' src/CMakeLists.txt
+
+# Fix incorrect version name
+sed -i 's/-interim git//g' src/version.h
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -105,12 +105,11 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a documentation/* COPYING *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-#Add icon
-cat $CWD/fceux.png > $PKG/usr/share/pixmaps/fceux.png
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh