aboutsummaryrefslogtreecommitdiff
path: root/games/antimicro
diff options
context:
space:
mode:
authorklaatu <klaatu@member.fsf.org>2022-03-06 19:10:56 +1300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-07 08:38:02 +0700
commitc952507e7f591796d2986112ec6e3633d91144fd (patch)
tree65ff2f6fd7c4edba0c3085446d07ba134c33042c /games/antimicro
parentc249864ba5785fb7ef99f11623da4972196ffa37 (diff)
games/antimicrox: renamed and updated for version 3.2.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/antimicro')
-rw-r--r--games/antimicro/README16
-rw-r--r--games/antimicro/antimicro.SlackBuild109
-rw-r--r--games/antimicro/antimicro.desktop18
-rw-r--r--games/antimicro/antimicro.info10
-rw-r--r--games/antimicro/doinst.sh7
-rw-r--r--games/antimicro/slack-desc19
6 files changed, 0 insertions, 179 deletions
diff --git a/games/antimicro/README b/games/antimicro/README
deleted file mode 100644
index 399fbaa1136e..000000000000
--- a/games/antimicro/README
+++ /dev/null
@@ -1,16 +0,0 @@
-Antimicro is a GUI application to intercept gamepad signals and
-translate them to keyboard and mouse events, so that you can use a
-gamepad with games that do not have native (or poor) gamepad support.
-
-It works for games you're playing on Linux or with WINE. It works with
-Steam or stand-alone games.
-
-Profiles
---------
-
-Some pre-built game controller profiles are available here:
-
-https://github.com/AntiMicro/antimicro-profiles
-
-These allow you to download button mappings for popular games so that
-you don't have to configure them yourself.
diff --git a/games/antimicro/antimicro.SlackBuild b/games/antimicro/antimicro.SlackBuild
deleted file mode 100644
index 293f8938cd60..000000000000
--- a/games/antimicro/antimicro.SlackBuild
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/bash
-# Slackware build script for antimicro
-# Copyright 2015-2016 Klaatu Wellington, NZ
-#
-# GNU All-Permissive License
-# Copying and distribution of this file, with or without modification,
-# are permitted in any medium without royalty provided the copyright
-# notice and this notice are preserved. This file is offered as-is,
-# without any warranty.
-
-# 20220219 bkw: Modified by SlackBuilds.org:
-# - fix build on Slackware 15.0.
-# - remove option to build with qt5: it fails.
-# - add qt4 as a dep.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=antimicro
-VERSION=${VERSION:-2.23}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-DOCDIR=${DOCDIR:-/usr/doc}
-MANDIR=${MANDIR:-/usr/man}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-# 20220219 bkw: ordered comparison of pointer with integer... this is
-# really a bit too picky, IMO.
-sed -i '/if *(joysticks *>/s, *> *0 *),),' src/mainwindow.cpp
-
-# 20220219 bkw: put man page in right place.
-sed -i 's,share/man,man,' other/CMakeLists.txt
-
-mkdir -p build
-cd build
-QT_SELECT=4 cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DUSE_SDL_2=ON \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install/strip DESTDIR=$PKG
-cd ..
-
-# 20220219 bkw: binary stripped, man page already gzipped.
-
-# 20220219 bkw: .desktop file needs absolute path to binary (because
-# /usr/games might not be in someone's $PATH) and icon (because it's
-# not in /usr/share/icons).
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
-
-mkdir -p $PKG/$DOCDIR/$PRGNAM-$VERSION
-cp -a README.md BuildOptions.md gpl.txt Resources.txt \
- ProfileTips.md other/40-uinput.rules \
- $PKG/$DOCDIR/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/$DOCDIR/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/antimicro/antimicro.desktop b/games/antimicro/antimicro.desktop
deleted file mode 100644
index 857a322dcecb..000000000000
--- a/games/antimicro/antimicro.desktop
+++ /dev/null
@@ -1,18 +0,0 @@
-[Desktop Entry]
-Name=AntiMicro
-Comment=Use a gamepad to control a variety of programs
-Name[sr]=Анти-микро
-Comment[sr]=Користите џојстик или играћу тастатуру за управљање различитим програмима
-Name[fr]=AntiMicro
-Comment[fr]=Utilisez une manette de jeu pour commander un logiciel
-Name[de]=AntiMicro
-Comment[de]=Nutze das Gamepad um Programme/Spiele zu steuern
-Comment[uk]=Використовуйте ігровий маніпулятор для керування програмами
-Exec=/usr/games/antimicro
-Icon=/usr/share/pixmaps/antimicro.png
-StartupNotify=true
-Terminal=false
-Type=Application
-Categories=Qt;Utility;
-MimeType=application/x-amgp;
-Keywords=game;controller;keyboard;joystick;mouse;
diff --git a/games/antimicro/antimicro.info b/games/antimicro/antimicro.info
deleted file mode 100644
index 5e7c0e2abbfa..000000000000
--- a/games/antimicro/antimicro.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="antimicro"
-VERSION="2.23"
-HOMEPAGE="https://github.com/AntiMicro/antimicro"
-DOWNLOAD="https://github.com/AntiMicro/antimicro/archive/2.23/antimicro-2.23.tar.gz"
-MD5SUM="b63397e9e6d0bb06d98b0931a86b3427"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="qt4"
-MAINTAINER="Klaatu"
-EMAIL="klaatu@member.fsf.org"
diff --git a/games/antimicro/doinst.sh b/games/antimicro/doinst.sh
deleted file mode 100644
index 9a8ded3c6034..000000000000
--- a/games/antimicro/doinst.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
diff --git a/games/antimicro/slack-desc b/games/antimicro/slack-desc
deleted file mode 100644
index b2e069eb2922..000000000000
--- a/games/antimicro/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-antimicro: antimicro (gamepad to keypress)
-antimicro:
-antimicro: Antimicro is a graphical program used to map keyboard keys and mouse
-antimicro: controls to a gamepad. Useful for playing PC games with no gamepad
-antimicro: or poor gamepad support.
-antimicro:
-antimicro: http://github.com/AntiMicro/antimicro
-antimicro:
-antimicro:
-antimicro:
-antimicro: