aboutsummaryrefslogtreecommitdiff
path: root/development
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2024-11-02 21:00:36 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-04 01:17:31 +0700
commitf28325cee58b442c15877d67a57cfbc8e7e256d6 (patch)
tree170ba32a641b4cbabe83126f033355000487f6a9 /development
parente2872659121413593311432e06774d96a8b0ef7a (diff)
development/jupyterlab: Update for 4.0.13
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyterlab/README4
-rw-r--r--development/jupyterlab/jupyterlab.SlackBuild22
-rw-r--r--development/jupyterlab/jupyterlab.desktop11
-rw-r--r--development/jupyterlab/jupyterlab.info8
-rw-r--r--development/jupyterlab/no-nbclassic.patch15
-rw-r--r--development/jupyterlab/slack-desc2
6 files changed, 13 insertions, 49 deletions
diff --git a/development/jupyterlab/README b/development/jupyterlab/README
index 187b0fea5232..b0d2258a71b1 100644
--- a/development/jupyterlab/README
+++ b/development/jupyterlab/README
@@ -2,11 +2,7 @@ JupyterLab is the next-generation user interface for Project Jupyter
offering all the familiar building blocks of the classic
Jupyter Notebook (notebook, terminal, text editor, file browser,
rich outputs, etc.) in a flexible and powerful user interface.
-JupyterLab will eventually replace the classic Jupyter Notebook.
Jupyter kernels are needed for JupyterLab to be fully functional. The
following kernels are currently available as SlackBuilds:
* jupyter-ipykernel
-
-jupyterlab 3.5.3 is the last possible version for Slackware 15.0.
-Newer versions would require a newer jupyterlab_server.
diff --git a/development/jupyterlab/jupyterlab.SlackBuild b/development/jupyterlab/jupyterlab.SlackBuild
index ff9922993163..1d6419b0af0a 100644
--- a/development/jupyterlab/jupyterlab.SlackBuild
+++ b/development/jupyterlab/jupyterlab.SlackBuild
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyterlab
-VERSION=${VERSION:-3.5.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.0.13}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -62,20 +62,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Remove nbclassic dependency
-sed -e '/nbclassic/d' -i setup.cfg
-patch -p1 < $CWD/no-nbclassic.patch
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
-# Remove jupyter-notebook requirement from setup.cfg
-sed -e '/notebook/d' -i setup.cfg
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
-# Fix /etc/jupyter path
-sed 's|etc|/etc|' -i setup.py
-
-python3 setup.py install --root=$PKG
-
-# Install desktop file
-install -Dm644 $CWD/jupyterlab.desktop $PKG/usr/share/applications/jupyterlab.desktop
+# Fix /etc/jupyter path
+mv $PKG/{usr/,}etc
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/development/jupyterlab/jupyterlab.desktop b/development/jupyterlab/jupyterlab.desktop
deleted file mode 100644
index 93fe9409aa55..000000000000
--- a/development/jupyterlab/jupyterlab.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=JupyterLab
-Comment=Run JupyterLab
-Exec=jupyter-lab %f
-Terminal=true
-Type=Application
-Icon=jupyterlab
-StartupNotify=true
-MimeType=application/x-ipynb+json;
-Categories=Development;Education;
-Keywords=python;
diff --git a/development/jupyterlab/jupyterlab.info b/development/jupyterlab/jupyterlab.info
index adab7681d499..af6f2f1e047f 100644
--- a/development/jupyterlab/jupyterlab.info
+++ b/development/jupyterlab/jupyterlab.info
@@ -1,10 +1,10 @@
PRGNAM="jupyterlab"
-VERSION="3.5.3"
+VERSION="4.0.13"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyterlab/jupyterlab-3.5.3.tar.gz"
-MD5SUM="4b339d6c521fb12314a5b540512f6d85"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyterlab/jupyterlab-4.0.13.tar.gz"
+MD5SUM="c22cc9e0b0c65ba664b84e9a6816533d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="jupyter-notebook_shim nodejs jupyterlab_server jupyter-ipykernel"
+REQUIRES="jupyter-ipykernel jupyter-notebook_shim jupyterlab_server nodejs python3-async-lru"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"
diff --git a/development/jupyterlab/no-nbclassic.patch b/development/jupyterlab/no-nbclassic.patch
deleted file mode 100644
index de633573404e..000000000000
--- a/development/jupyterlab/no-nbclassic.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-This patch was taken from Arch Linux repositories:
-https://github.com/archlinux/svntogit-community/blob/packages/jupyterlab/trunk/no-nbclassic.patch
-diff --git a/jupyterlab/labapp.py b/jupyterlab/labapp.py
-index 1eb56b22fe..5a401a0fdf 100644
---- a/jupyterlab/labapp.py
-+++ b/jupyterlab/labapp.py
-@@ -19,7 +19,7 @@ from jupyterlab_server import (
- WorkspaceImportApp,
- WorkspaceListApp,
- )
--from nbclassic.shim import NBClassicConfigShimMixin
-+from notebook_shim.shim import NotebookConfigShimMixin as NBClassicConfigShimMixin
- from traitlets import Bool, Instance, Unicode, default
-
- from ._version import __version__
diff --git a/development/jupyterlab/slack-desc b/development/jupyterlab/slack-desc
index 20cce946a521..3a971cf9c915 100644
--- a/development/jupyterlab/slack-desc
+++ b/development/jupyterlab/slack-desc
@@ -12,7 +12,7 @@ jupyterlab: JupyterLab is the next-generation user interface for Project Jupyter
jupyterlab: offering all the familiar building blocks of the classic
jupyterlab: Jupyter Notebook (notebook, terminal, text editor, file browser,
jupyterlab: rich outputs, etc.) in a flexible and powerful user interface.
-jupyterlab: JupyterLab will eventually replace the classic Jupyter Notebook.
+jupyterlab:
jupyterlab:
jupyterlab:
jupyterlab: