aboutsummaryrefslogtreecommitdiff
path: root/development
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2021-07-19 06:51:58 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-07-19 16:23:30 +0700
commitc80f01d33a52002a34157a40827cbdafc4444e7e (patch)
tree0671a8900392070e5ccb6bd123f759daaf02ec1e /development
parent741b3532a4e9156d8b0bed475690e8742b32f16e (diff)
development/editorconfig-core-c: Removed (added to Slackware).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/editorconfig-core-c/README7
-rw-r--r--development/editorconfig-core-c/editorconfig-core-c.SlackBuild112
-rw-r--r--development/editorconfig-core-c/editorconfig-core-c.info10
-rw-r--r--development/editorconfig-core-c/man-directory.patch23
-rw-r--r--development/editorconfig-core-c/slack-desc19
5 files changed, 0 insertions, 171 deletions
diff --git a/development/editorconfig-core-c/README b/development/editorconfig-core-c/README
deleted file mode 100644
index dab1af1845ee..000000000000
--- a/development/editorconfig-core-c/README
+++ /dev/null
@@ -1,7 +0,0 @@
-EditorConfig makes it easy to maintain the correct coding style when
-switching between different text editors and between different projects.
-
-The EditorConfig project maintains a file format and plugins for various
-text editors which allow this file format to be read and used by those
-editors. For information on the file format and supported text editors,
-see the EditorConfig website.
diff --git a/development/editorconfig-core-c/editorconfig-core-c.SlackBuild b/development/editorconfig-core-c/editorconfig-core-c.SlackBuild
deleted file mode 100644
index 0594d0a7ea28..000000000000
--- a/development/editorconfig-core-c/editorconfig-core-c.SlackBuild
+++ /dev/null
@@ -1,112 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for editorconfig-core-c
-
-# Copyright 2019 David Demelier, France
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=editorconfig-core-c
-VERSION=${VERSION:-0.12.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# fix man path installation
-patch -p0 < $CWD/man-directory.patch
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
- rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.a
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGELOG LICENSE README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/editorconfig-core-c/editorconfig-core-c.info b/development/editorconfig-core-c/editorconfig-core-c.info
deleted file mode 100644
index 9a87350ad5a4..000000000000
--- a/development/editorconfig-core-c/editorconfig-core-c.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="editorconfig-core-c"
-VERSION="0.12.1"
-HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c"
-DOWNLOAD="http://github.com/editorconfig/editorconfig-core-c/archive/v0.12.1/editorconfig-core-c-0.12.1.tar.gz"
-MD5SUM="f15a4d417c405c8de54f132dc3429e46"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="David Demelier"
-EMAIL="markand@malikania.fr"
diff --git a/development/editorconfig-core-c/man-directory.patch b/development/editorconfig-core-c/man-directory.patch
deleted file mode 100644
index 74d5db6733a3..000000000000
--- a/development/editorconfig-core-c/man-directory.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- doc/CMakeLists.txt.orig 2019-02-16 20:30:36.724781344 +0100
-+++ doc/CMakeLists.txt 2019-02-16 20:31:01.294782000 +0100
-@@ -107,17 +107,17 @@
- # we need to exclude it when installing man3. Same for
- # editorconfig-format.3
- install(DIRECTORY ${EC_MANPAGE3_DIR}
-- DESTINATION share/man
-+ DESTINATION man
- PATTERN editorconfig.3 EXCLUDE
- PATTERN editorconfig-format.3 EXCLUDE
- REGEX ._include_. EXCLUDE)
-
- install(FILES
- ${EC_MANPAGE1_DIR}/editorconfig.1
-- DESTINATION share/man/man1)
-+ DESTINATION man/man1)
- install(FILES
- ${EC_MANPAGE5_DIR}/editorconfig-format.5
-- DESTINATION share/man/man5)
-+ DESTINATION man/man5)
-
- # "make clean" should also clean generated docs
- set_directory_properties(PROPERTIES
diff --git a/development/editorconfig-core-c/slack-desc b/development/editorconfig-core-c/slack-desc
deleted file mode 100644
index ca84f7de288f..000000000000
--- a/development/editorconfig-core-c/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-editorconfig-core-c: editorconfig-core-c (EditorConfig core library written in C)
-editorconfig-core-c:
-editorconfig-core-c: EditorConfig makes it easy to maintain the correct coding style when
-editorconfig-core-c: switching between different text editors and between different
-editorconfig-core-c: projects.
-editorconfig-core-c:
-editorconfig-core-c: The EditorConfig project maintains a file format and plugins for
-editorconfig-core-c: various text editors which allow this file format to be read and used
-editorconfig-core-c: by those editors. For information on the file format and supported
-editorconfig-core-c: text editors, see the EditorConfig website.
-editorconfig-core-c: