aboutsummaryrefslogtreecommitdiff
path: root/development
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2022-03-14 13:34:35 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-18 00:26:03 +0700
commit93edeb4e2047ae8bdd8c24fea83bfabd9716bb86 (patch)
tree12df4c99ebde4f3a1110222bafa18a9c4ccd9037 /development
parent8078f6f92e193e983ed4bdea5db94d81263e170e (diff)
python/python3-psycopg2: renamed from psycopg2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/psycopg2/README3
-rw-r--r--development/psycopg2/psycopg2.SlackBuild86
-rw-r--r--development/psycopg2/psycopg2.info10
-rw-r--r--development/psycopg2/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/development/psycopg2/README b/development/psycopg2/README
deleted file mode 100644
index ffaef2289dd4..000000000000
--- a/development/psycopg2/README
+++ /dev/null
@@ -1,3 +0,0 @@
-psycopg is a PostgreSQL database adapter for Python. It supports the
-full Python DBAPI 2.0, and is thread safe at level 2. psycopg was
-designed for heavily multi-threaded applications.
diff --git a/development/psycopg2/psycopg2.SlackBuild b/development/psycopg2/psycopg2.SlackBuild
deleted file mode 100644
index 611784d37c95..000000000000
--- a/development/psycopg2/psycopg2.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for psycopg2
-
-# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
-# Copyright (c) 2018-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright (c) 2007 Daniel de Kok <moc.mikciat@leinad>
-# Copyright (c) 2010-2011, 2013 Carlos Corbacho <carlos@strangeworlds.co.uk>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=psycopg2
-VERSION=${VERSION:-2.9.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS INSTALL LICENSE NEWS README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/psycopg2/psycopg2.info b/development/psycopg2/psycopg2.info
deleted file mode 100644
index 8232663289cd..000000000000
--- a/development/psycopg2/psycopg2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="psycopg2"
-VERSION="2.9.3"
-HOMEPAGE="http://initd.org/psycopg/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/psycopg2/psycopg2-2.9.3.tar.gz"
-MD5SUM="1415674b95557329867ce68bd841a48b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="postgresql"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/development/psycopg2/slack-desc b/development/psycopg2/slack-desc
deleted file mode 100644
index dfc7a0da87a5..000000000000
--- a/development/psycopg2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-psycopg2: psycopg2 (Python PostgreSQL bindings)
-psycopg2:
-psycopg2: psycopg is a PostgreSQL database adapter for Python. It supports the
-psycopg2: full Python DBAPI 2.0, and is thread safe at level 2. psycopg was
-psycopg2: designed for heavily multi-threaded applications.
-psycopg2:
-psycopg2: The psycopg2 website can be found at:
-psycopg2: http://initd.org/tracker/psycopg/wiki/PsycopgTwo
-psycopg2:
-psycopg2:
-psycopg2: