aboutsummaryrefslogtreecommitdiff
path: root/development/zope.testing/zope.testing.SlackBuild
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2023-07-04 15:15:34 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-05 23:46:28 +0700
commit0daf86d737c4ad07d2f86a09e7b834a7a89e47e2 (patch)
tree1ee6bff9e1b07c7d05fd7bdceba71783961b3f2e /development/zope.testing/zope.testing.SlackBuild
parentca1de4da512dbe960c4b60b43e58738eae6dd6e6 (diff)
development/zope.testing: updated for version 5.0.1 Python3. New maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/zope.testing/zope.testing.SlackBuild')
-rw-r--r--development/zope.testing/zope.testing.SlackBuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/development/zope.testing/zope.testing.SlackBuild b/development/zope.testing/zope.testing.SlackBuild
index 3577e0988ef0..01dd6587aa15 100644
--- a/development/zope.testing/zope.testing.SlackBuild
+++ b/development/zope.testing/zope.testing.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for zope.testing
# Copyright 2013 Mikko Värri, Finland
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zope.testing
-VERSION=${VERSION:-4.1.3}
+VERSION=${VERSION:-5.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,12 +61,15 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.rst COPYRIGHT.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
@@ -76,4 +80,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
-