aboutsummaryrefslogtreecommitdiff
path: root/development/sdcc/sdcc.SlackBuild
diff options
context:
space:
mode:
authorKyle Guinn <elyk03@gmail.com>2021-04-09 21:23:34 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-04-10 17:04:44 +0700
commitf0fa5abcefaf564e209aed601e5f8527c1a90d78 (patch)
tree28e736f1350eb431202e98d505e1b6cfd981c850 /development/sdcc/sdcc.SlackBuild
parent24b457bbd5cdcb803d844815869d47267a93907f (diff)
development/sdcc: Updated for version 4.1.0.
Signed-off-by: Kyle Guinn <elyk03@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/sdcc/sdcc.SlackBuild')
-rw-r--r--development/sdcc/sdcc.SlackBuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/development/sdcc/sdcc.SlackBuild b/development/sdcc/sdcc.SlackBuild
index 8e6a39a06f26..d98410a08e13 100644
--- a/development/sdcc/sdcc.SlackBuild
+++ b/development/sdcc/sdcc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sdcc
-# Copyright 2014-2020 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sdcc
-VERSION=${VERSION:-4.0.0}
+VERSION=${VERSION:-4.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,9 +64,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-src-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
+cd $PRGNAM
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
@@ -81,10 +81,6 @@ patch -p1 < $CWD/patches/source-tree.patch
# Avoid creating empty man directories.
sed -i '/(man1dir)/d' sim/ucsim/doc/Makefile.in
-# make considers device/lib/pic14/aclocal.m4 out-of-date and tries to
-# rebuild it using aclocal-1.16 which doesn't exist yet on Slackware 14.2.
-(cd device/lib/pic14 && autoreconf -vif)
-
# Requires lyx, latex2html, possibly others. Untested.
if [ "${ENABLE_DOC:-no}" != 'no' ]; then
enable_doc='--enable-doc'