aboutsummaryrefslogtreecommitdiff
path: root/development/sdcc/sdcc.SlackBuild
diff options
context:
space:
mode:
authorKyle Guinn <elyk03@gmail.com>2018-03-19 22:36:50 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-24 06:50:38 +0700
commit9a9e4b5cc13ec88dfc28b8572cc4d27f44ffb472 (patch)
tree051b31bb3d8d766eaff8bf505a0e570c67ed0a93 /development/sdcc/sdcc.SlackBuild
parent6110276104165414eed5239e8bbb053e72ed8da6 (diff)
downloadslackbuilds-9a9e4b5cc13ec88dfc28b8572cc4d27f44ffb472.tar.xz
development/sdcc: Updated for version 3.7.0.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'development/sdcc/sdcc.SlackBuild')
-rw-r--r--development/sdcc/sdcc.SlackBuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/development/sdcc/sdcc.SlackBuild b/development/sdcc/sdcc.SlackBuild
index fd2a4737529f..39d5bcb956fc 100644
--- a/development/sdcc/sdcc.SlackBuild
+++ b/development/sdcc/sdcc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sdcc
-# Copyright 2014-2017 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2018 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sdcc
-VERSION=${VERSION:-3.6.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.7.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -64,15 +64,12 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-src-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
+cd $PRGNAM
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-# Don't clobber bfd.info from Slackware's binutils package.
-sed -i 's/^\(INFO_DEPS =\).*/\1/' support/sdbinutils/bfd/doc/Makefile.in
-
# A few Makefiles install (copy) the source tree _after_ building, and
# accidentally install a bunch of build byproducts which they try to clean
# up afterwards. Delete some byproducts that they missed.
@@ -115,8 +112,6 @@ make install DESTDIR=$PKG
find $PKG -exec file {} + | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-rmdir $PKG/usr/info
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild