aboutsummaryrefslogtreecommitdiff
path: root/development/rstudio-desktop/rstudio-desktop.SlackBuild
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2023-03-19 16:48:27 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-01 09:14:21 +0700
commit3071d78697c65e93c3ade3200c53f922b6076d45 (patch)
tree86550ea2e3c16763141de60f1da69e00114dc976 /development/rstudio-desktop/rstudio-desktop.SlackBuild
parentada4e15677385d938f11bd4f0641834e9a430d60 (diff)
development/rstudio-desktop: Updated for version 2023.03.0+386.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/rstudio-desktop/rstudio-desktop.SlackBuild')
-rw-r--r--development/rstudio-desktop/rstudio-desktop.SlackBuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/development/rstudio-desktop/rstudio-desktop.SlackBuild b/development/rstudio-desktop/rstudio-desktop.SlackBuild
index 26265e9982ed3..37e1932318ad7 100644
--- a/development/rstudio-desktop/rstudio-desktop.SlackBuild
+++ b/development/rstudio-desktop/rstudio-desktop.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for rstudio-desktop
# Copyright 2018 Ekin Akoglu, Erdemli/Mersin, Turkey <ekinakoglu@gmail.com>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,9 +27,9 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rstudio-desktop
SRCNAM=rstudio
-VERSION=${VERSION:-2022.12.0+353}
+VERSION=${VERSION:-2023.03.0+386}
SRCVER=${SRCVER:-$(echo $VERSION | sed 's/+/-/g')}
-GITCOMMIT_VER=7d165dc
+GITCOMMIT_VER=3c53477
NODE_VER=${NODE_VER:-16.14.0}
PANDOCVER=current
BUILD=${BUILD:-1}
@@ -44,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -85,8 +82,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# patches
-patch -p1 < $CWD/pandoc_version.patch # Do not use outdated pandoc version number
+# Do not use outdated pandoc version number
+patch -p1 < $CWD/pandoc_version.patch
cd dependencies/common
mkdir -p pandoc/$PANDOCVER
@@ -100,12 +97,11 @@ cd node && tar xvf $CWD/node-v$NODE_VER-linux-x64.tar.gz
cd ../
mv node/node-v$NODE_VER-linux-x64 node/$NODE_VER
export PATH=$TMP/$SRCNAM-$SRCVER/dependencies/common/node/$NODE_VER/bin:$PATH # use bundled node
-cd $TMP/$SRCNAM-$SRCVER/src/gwt/panmirror/src/editor
-# Prevent creation of cache files in /usr/local/share/
-env YARN_DISABLE_SELF_UPDATE_CHECK=true \
- YARN_CACHE_FOLDER=$TMP/$SRCNAM-$SRCVER/cache/yarn \
- yarn install --ignore-engines
+# Panmirror is picked up now from Quarto repo
+cd $TMP/$SRCNAM-$SRCVER/src/gwt/lib
+unzip $CWD/rstudio-cherry-blossom.zip
+mv quarto-release-rstudio-cherry-blossom quarto
# Fix links for src/cpp/session/CMakeLists.txt
cd $TMP/$SRCNAM-$SRCVER/dependencies
@@ -113,6 +109,10 @@ ln -sfT common/dictionaries dictionaries
ln -sfT common/mathjax-27 mathjax-27
ln -sfT common/pandoc pandoc
+# Prevent creation of cache files in /usr/local/share/
+export YARN_DISABLE_SELF_UPDATE_CHECK=true
+export YARN_CACHE_FOLDER=$TMP/$SRCNAM-$SRCVER/cache/yarn
+
cd $TMP/$SRCNAM-$SRCVER
# Environmental variables (RStudio version numbers, architecture, etc.)