aboutsummaryrefslogtreecommitdiff
path: root/development/python3-matplotlib/python3-matplotlib.SlackBuild
diff options
context:
space:
mode:
authorAndrew Clemons <andrew.clemons@gmail.com>2021-10-24 20:38:07 +1300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-27 08:40:37 +0700
commitc56367982ca4e45b9be10fb639c96abbd4fd3d95 (patch)
tree90ca74f159bc8bd2a10549434dccf03284412f95 /development/python3-matplotlib/python3-matplotlib.SlackBuild
parentab356d80000f32fdf9312da1b7e29a672b790f8c (diff)
development/python3-matplotlib: Build offline.
The SlackBuild tries to download freetype during build. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/python3-matplotlib/python3-matplotlib.SlackBuild')
-rw-r--r--development/python3-matplotlib/python3-matplotlib.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/development/python3-matplotlib/python3-matplotlib.SlackBuild b/development/python3-matplotlib/python3-matplotlib.SlackBuild
index 829d1caa30bf4..419a58e216dbd 100644
--- a/development/python3-matplotlib/python3-matplotlib.SlackBuild
+++ b/development/python3-matplotlib/python3-matplotlib.SlackBuild
@@ -71,6 +71,9 @@ cd $TMP
rm -rf $SRCNAM-$TARBALL_VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$TARBALL_VERSION
+mkdir -p build
+tar -C build -xvf $CWD/freetype-2.6.1.tar.gz
+tar -C build -xvf $CWD/qhull-2020-src-8.0.2.tgz
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -87,11 +90,6 @@ then
sed -i "s|#tests = False|tests = True|" setup.cfg
fi
-# Use modified setupext.py to make sure that the build process gets
-# interrupted if requirements are not fulfilled
-#
-#cat "${CWD}/setupext.py" > setupext.py
-
python3 setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \